`socks5` option in docu

According to the documentation for kubectl the coudflared has to be started with
--socks5=true

However I don’t see that config in the argo-tunnel documentation and I am also not sure whether I can provide the option in the config file.

  1. Is the docu incomplete? If yes I can file a bug…
  2. Can I use the option in the config file? Example
    hostname: "kube.mydomain.com"
    url: tcp://kubernetes.internal:6443
    lb_pool: kube
    socks5: true
    

Seems to work at least the daemon started with above config and did not complain.

 [email protected] - cloudflared tunnel for k8s
   Loaded: loaded (/etc/systemd/system/[email protected]; enabled; vendor preset: enabled)
   Active: active (running) since Mon 2020-11-02 10:56:38 CET; 8min ago
 Main PID: 6651 (cloudflared)
    Tasks: 13 (limit: 4915)
   Memory: 16.7M
   CGroup: /system.slice/system-cloudflared.slice/[email protected]
           └─6651 /usr/bin/cloudflared tunnel --config /etc/cloudflared/k8s.yml

Nov 02 10:56:40 node002 cloudflared[6651]: INFO[2020-11-02T10:56:40+01:00] Route propagating, it may take up to 1 minute for your new route to become functional
Nov 02 10:56:40 node002 cloudflared[6651]: INFO[2020-11-02T10:56:40+01:00] Connected to FRA
Nov 02 10:56:41 node002 cloudflared[6651]: INFO[2020-11-02T10:56:41+01:00] Connected to VIE

So I assume lack of documentation then: [https://github.com/cloudflare/cloudflare-docs/pull/212](https://PR created)