SMTP not working, exclamation symbol at MX record


After register our domain on CloudFlare our Zen cart webshop SMTP stop working.

I read this article: Set up email records · Cloudflare DNS docs
and try to make changes, but there were errors.

First, i can't create a new A or AAA record with name mail because there is a CNAME record with this name. If i change that CNAME to A a can save.

But in the next step when i create MX record with name @ can't save the values, the name change to ""
and SMTP not working from our zen cart webshop.

Can you help me, how to set up DNS - MX correctly?
Thank you!

What is the domain you are having issues with? What value are you trying to set for the MX record? What other records do you have?

the domain is

type: MX:
name: typing @ but after save i see
TTL: auto
priority: 0

But, i changed A record with name "mail" from "proxied" to "DNS only" and it seems smtp works again.
dig mx +short

Your mail server is proxied, it should be :grey:

This are the records in DNS and SMTP not works

Type Name Content Proxy status TTL Actions
A mail DNS only Auto
MX DNS only Auto 0
TXT _dmarc v=DMARC1;  p=none; rua=mailto:317bcc6bbcdd4735[email protected] DNS only Auto

Under Email menu i see this:

DNS records
Email DNS records misconfigured

By the Email menu, do you mean Email Routing? You do not use that feature with your own mailserver. Email Routing is a forwarding service that you can use if you don’t have domain email at a mailserver.

this is what i see on DNS page

and Email routing page

SMTP test on mytoolbox:     
Pref: 0 
IP Address:
TTL: 5 min

SMTP Reverse DNS Mismatch

Beyond your zen art issue in another thread how are you determining SMTP is not working? Have you sent an email from gmail? Does it arrive? If not, what is the specific error message received when it bounces?

1 Like

Based on what you have shown, everything is set correctly at Cloudflare.

The triangle next to your MX hostname is because you are using the same IP as one or more proxied hostnames. If you run your email on your webserver using a hostname in the same domain, that is unavoidable.

The Email Routing indicates that it is disabled. That is good. You don’t need to do anything there.

The reverse DNS mismatch can only be changed by your hosting provider, if it can be changed at all. It may not be a relevant error.

Answering all of the questions @cscharff asked is what you need to move forward.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.