SMTP mail doesn't works after add the site to Cloudflare

After adding the site to Cloudflare my site SMTP mail doesn’t works, here is the screenshot of cloudflare dns & my mail server

After adding a mx record here is a notice

(Some of your DNS only records are exposing IPs that are proxied through Cloudflare. Make sure to proxy all A, AAAA, and CNAME records pointing to proxied records to avoid exposing your origin IP.)

So could you please help me to set up my WordPress site SMTP mail working?

mail server info
chromastudios.photography

Hi @chromastudios,

Have a look at

In summary, your mail related records need to me :grey: and you need to use one of those unproxied hostnames to connect to for SMTP.

1 Like

Thank you for sharing the video tutorial on email troubleshooting. But it doesn’t works

Please check the 1 min 35-sec video, here is what I did.

And please suggest to me what should I do?

That won’t work, there’s nothing for SMTP to connect to as all your records are proxied.

This is usually done by setting the mail A record to :grey: and pointing the MX record there and using that hostname to connect to.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.