Smart TV Browser


#1

I have a Samsung Smart TV which as a browser built in, none of the sites I manage through Cloudflare will load. No error messages are given it just sits a waits without loading the sites. The sites range from basic PHP to Wordpress. I have tried other sites and they load fine. One site I manage is for subscription videos so really need it accessible on SmartTV’s? and example site which won’t load is https://tigers.mysportstickets.co.uk

I have firmware updated the TV to the latest version and still no joy. I don’t get any errors on my server so I’m not convinced the request is making it through Cloudflare?


Samsung Smart Tv Browser support
Samsung Smart Tv Browser support
#2

The underlying OS of Samsung’s smart TVs seems to be… um interesting. It may not support SNI which is used by Cloudflare universal SSL certificates. A dedicated certificate may help:


#3

This topic was automatically closed after 14 days. New replies are no longer allowed.


#4

Tried to reply on the other topic but its closed.

Topik Link: Smart TV Browser

My website is hosted on heroku and heroku also use SNI.

When i try to access my site on the smarttv browser it only works if I stop using cloudflare to manage the site and use it only for DNS.

If I turn the the cloud to orange the website stop loading on the smart tv browser as described on teh other topic.

As heroku uses SNI, this is not the problem. Any hint on what could cause this?


#5

Here’s what I can find online:

https://developer.samsung.com/tv/develop/specifications/web-engine-specifications

Apparently, 2017-2018 TVs uses Chromium, while 2015-2016 TVs uses Webkit. All of which supports TLS 1.2 and all but the 2017 models, supports AES_256_GCM for TLS.

Here’s a thought: if you are on Cloudflare’s free plan, it may be due to Tizen does not support ECC keys. Note that I am unable to find any documentation on whether Tizen supports ECC.


#6

There you go, I merged them, note that after 14 days of inactivity the threads automatically close.