Slow website page loads

Does anyone have advice on how to identify the cause of my site’s long load times?
It is a simple 1 page WordPress site, using a Themify theme and has several pictures. It is hosted on GoDaddy and uses Cloudflare for DNS and a free SSL Cert.

I ran a tracert and GTMetrix and WebPageTest and all show the page loads in 3 sec or less. It scores reasonably high for speed. There are no major re-directs that I see. These test sites suggest the page loads in 3-seconds, which would be great. It took 29 seconds (by stop watch) to load this morning. I cleared the Cache between tries. It does not matter if I Temporarily bypass the Cloudflare cache. I already tried turning off the Cache that Themify has and that did not make a difference.

This has been going on for a long time. I tried to track down the problem in the past and never found the cause or solution. Trying again. I am not looking for a 1-2 second page load, but not many people will wait for 30 seconds, they will think the site is down.

I know that GoDaddy will say it is Cloudflare related. Is there any way to determine/prove if it is GoDaddy related, website theme related or Cloudflare related?

Traceert Feb 21

Thanks for your help/advice.

a tip, there will be several more ok, GoDaddy is good for buying domains but hosting is already a little doubtful since the speed is compared to InfinityFree which as the name says is free that is and very slow, look for hosting that use CPanel and have a considerable reference minimum, another thing, if you don’t have a cache plugin or it’s not configured well, I recommend just using 1 in the case of WP Fast Cache, the photo is a leopard, and use the Cloudflare CDN, this will decrease the time of page load in addition to decreasing storage usage.


" look for hosting that use CPanel"

My GoDaddy account has cPanel and I use it for configuration of the domain I do not have the basic GoDaddy account, it is 1 step higher.

"if you don’t have a cache plugin or it’s not configured well, "

Themify is a paid WP theme and it has a Cache designed for it. I shut it down to help trouble shoot the issue, since Cloudflare has a cache. Shutting it down had no effect on speed.

I am using Cloudflare CDN (as far as I know)

I can not figure out what is causing the delay. The page speed test shows that it loads in 3-sec.

Not sure if you tried to access it, but it is

If I can confirm it is a GoDaddy Issue, I will ask/make them fix it or I will leave.

I am thinking about trying AWS, but that will have a learning curve and little to no safety net.

I believe you’re not using the CDN since you need a key, but I think it’s your connection or connectivity route, I live in Brazil and it’s normal until fast because it’s Godaddy.

Try to access the page again in about 30 min. IF I just accessed it, it loads fast. After about 20 min, it is very slow. It just took me 15 seconds.
I do not think it is MY connection. I have a fiber gigabit connection. The page is hosted in US and I am in US. I do not have this issue on other pages… and other people who tried to help found the same problem.

THANKS for helping.

No , It is Free but it is Fast , Have you ever used it ?

I am Personally use InfintyFree for all my Domains it loads very fast an good

If you are talking to me… I never heard of it. I will research it.

1 Like

As @phsl.ofc metioned InfintyFree is slow I am telling , It is not Slow

Thanks… I will look into it. Wish I could pin down the cause of my slowness… I have no problem going to a different service.

1 Like

It took me 2.6 Seconds to Load all resources , It is Fast & Well , Maybe Someone Internet Issue on your end Please try your Internet Speed Test

Your Site also get Pretty Well Score in Google Website Test

Your Site is Ok , Loads fine for me , Can you try loading from different devices ?

When my page is recently accessed, it loads fast. clear your cache and try it again in about 15-20 min.

It has been consistent— for being fast if recently accessed and slow after a few minutes. Other people on Cloudflare Forum have reported similar slow response.

Here is a speed test from my laptop, wireless access to my network.

The Cloudflare Warp was recently added… the problem started before this… I set it up to see if it had any effect.

Ok then i will try loading after 30 Minutes & see if the Issue Continues

Cloudflare doesn’t make a site slower in most cases it makes the site fast

I believe it’s a matter of connectivity route, try using Cloudflare’s most of the time it improves.

I think you got it wrong, it’s free and for a free service it’s the best, but GoDaddy is paid and to be honest it’s very expensive for what it offers, you know?

1 Like

my connection the same way you tested.

your site’s rating on speed test sites is the best so I think it’s a connectivity error for me, I’m from Brazil, it’s normal

Yes… different systems, different locations. When the site has not been recently accessed it is slow. After it has been accessed, even by different computers, it loads fast.

1 Like

I am already using Clourdlare’s

Is there any chance the GoDaddy server goes into a hibernation mode or something like that?

It might sound crazy, but that is how it is acting. If the web site is not accessed in 30min or more it takes between 15 and 29 seconds to load. If I access the site on a different computer, right after it will load fast on that computer.

Wait 30 min and it will load slow on the computer it just loaded fast, so I know it is not a computer issue.

This slowness is certainly not caused by Cloudflare. Your one-pager could benefit from a Cache Everything cache level, which you set with a page rule. Please search this community or for tutorials on how to best set it up.

I say it’s not Cloudflare because I just fetched from origin (the header CF-Cache-Status says “Dynamic”) and it took almost 30 seconds.

There are many, many things that could cause this in a WordPress installation, and I suggest your open a topic with Forums | to ask for advice, or else just Google it. There are plenty of tutorials on how to make a WP site fast under Cloudflare.

Things you should be looking at: setting a Cache-Control header with a max-age value of a day, as opposed to the current 1200 seconds. This is normally handled by your WP cache plugin, which must be instructed to cache your non-dynamic pages (such as the home page).

If your have $5 to dole out every month, you might wanna try Speed up WordPress with Cloudflare APO.