Slow Website load 1st time

I host a website to promote House Concerts and it only gets traffic around the time I have a concert scheduled. Too often it will take 30-40 seconds for my site to load if I have not visited it in a while. If I do a Page Speed Test of the address when I have not visited the site in a while, I will get a time out error on that test. If I go to the site… and it takes 40 seconds to load. If I then do a page speed test I get good scores (92).

If I bypass the Cloudflare cache, it does not seem to happen. Could it be related to the cache here? Is there a way to prevent the delay if it is?

Hosted on GoDaddy

Thanks in advance

Gary DZ

It seems that you only have a static page. Why don’t you use Cloudflare Pages?

Thanks… I will read up about it. I posted a question a couple weeks ago asking for a GoDaddy alternative. My contract ends in March.

I have a couple related questions.

Can I use Wordpress and Themify (Word Press Theme) in Cloudflare Pages? I currently have 3 pages hosted on CloudFlare. It looks like I will be able to do three.

Thanks again.

Gary DZ

I’m afraid not. You cannot host your Wordpress website on Cloudflare Pages. If you have another question, please ask it in a new thread.

I believe that with some development and tweaking, you could use headless WordPress. This would lead to a significant performance improvement.

At first glance, your site seems to be making a lot of requests, up to 150, just to load the main website. I understand that having one single landing page is cool, but it has its consequences since you are using WordPress (known to have a lot of bloated code) and many images.

What plan of CF do you have? Did you make any custom page rules to optimize your site?
It would help if you showed us all of your current settings (blurring those that might be confidential).

I have a Free CF account… I got it to use the free HTTPS certificate. I’d move my service to CF if they offered a similar plan as GoDaddy. GoDaddy was great for several years—no issues. The past few years their service and quality has become questionable.

I am an advanced NOVICE at best. I could not write a web page without WordPress and use Themify to make it look good. I realize both are not very efficient-- resource intensive… but I need the help. My site has fades and pull downs. The real slow loading is something new. I do not care if it takes 3-5 seconds to load, but 40 sec is too long. People will think it is down.

Well, I can’t check your page load time because my country has been blocked from your site.
Some solutions to speed up web pages using WordPress are minify and compresses CSS, JS, … should use some cache plugins and delete unnecessary themes / plugins.
In addition, I recommend using VPS instead of Shared Hosting, using Shared Hosting is really bad (in every way as speed, performance, …) and sometimes Cloudflare can’t help improve too much.

I apricate prior comments. I did a new experiment. I ran Page Speed twice, without accessing my web site.

The 1st time I got a time out error the second time I got a good score. I did not access the web site directly between tests… and they were only a few seconds apart.

Earlier today I went to my site and it took about 20 seconds to load the 1st time today and then about 2 seconds the next time.

Any other advice on trouble shooting the cause?

Thanks for the responses…

Is there any way to tell the source of the slow loads? The weak link in my page loads? I have used GoDaddy and Themify as my WordPress theme for years. It has not always loaded slow.

I initially tried Cloudflare for the free SSL certificate and it seemed to improve speeds as well. Since then it has gotten slower—much slower.

If I can show it is on GoDaddy side, it will help me decide to move my hosting. If it has something to do with CloudFlare Free SSL and DNS, I will switch back to use GoDaddy’s DNS.

baobaoxich— Sorry, I have most foreign visitor blocked. It is a site to promote House Concerts— pretty much everyone who attends is within driving distance. I had a lot of site hack attempts for overseas, so I figured I’d block them, since they are not potential attendees.

Seems to me like an issue at origin host/server. Are you on a shared web hosting?

Furthermore, for webpage (html) it’s set to not cache. In taht terms and my above question, looks like server has to do some processing first.

Cache headers are:

  • cache-control: max-age=0, no-cache, no-store, must-revalidate

Nevertheless, at first sight I was thinking it’s about TTFB, but then I got the "this website is only available via non-http, but somehow my Mozilla Firefox web browser redirected me to the HTTPS version).

UPDATE: After looking in depth a bit, it seems to me it is a TTFB issue.

  • considering the origin host/server PHP values/web server + WordPress

I am afraid SSL certificate does not have such impact on the speed itself.

Nevertheless, due to my curiosity, before moving to Cloudflare, was your Website working over HTTPS connection?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

First things first, you need to make it secure by having an valid SSL certificate present and installed at your origin host/server. If not, you may use Cloudflare Origin CA certificate.
Furthermore, turn on to the Full (Strict) SSL option at the SSL/TLS tab of Cloudflare dashboard.

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

In terms of a page load time, there are options and features - some are dependend on the Plan you are using - like Auto Minify, Rocket Loader, Brotli, HTTP/2, HTTP/3, 0-RTT, Polish & Mirage (Pro plan), Page Rules, Cache Level, Browser Cache TTL, Edge Cache TTL, etc.

1 Like

I apricate your help…. I will try to respond to all your questions and will include screen shots.

I am an advanced novice— so I know how to make my website and stumble my way through the complexities. I learn a lot on the way. I might not understand your question/comment correctly. But I will respond with as much detail as I think you are asking.

  1. Cache- I understand what it does, not sure how it is set up. My Themify theme has cache feature built it. Not sure if it is working correctly. When I click on the tab— I get 2 options (see pic). I did both options—regenerate and clear

Pasting your comment here for future reference

• cache-control: max-age=0, no-cache, no-store, must-revalidate

I can/will ask the Themify Forum how to check the cache –if you think that is the problem.

  1. TTFB issue— Not sure what it is. My PHP is current. See my cPanel settings.

  1. SSL- I did not expect it to speed it up. I just wanted SSL so visitors would not get a warning it was not SSL. I had a free SSL certificate from a different company. I needed to update it every 90 days. I switched to free CloudFlare because it lasted so long.

  2. My CloudFlare is set to Full Strict (see attached)

  3. My SSl Certificate is OK (see attached) and it is from CloudFlare.

Thanks again.

I’m not seeing 30-40 second load times on my first browser visit. Maybe 10 seconds, tops. It’s great after that.

I suggest you try some other tests, like,, and

If my site is recently accessed, it loads faster/fast and I get high scores. Here is a Speed test I did recently before accessing the site and then after I accessed the site—which took about 30 sec to load.

I ran each site you listed… but the scores might be higher because I have been recently accessing the site.

I did GTMetrix 1st and got a 404

I had Canada blocked… I was able to run GTMetrix. It got a high score, but again, I just accessed the website. I will try the speed test sites tomorrow, before accessing the website.

That’s a 403 because you’ve blocked Non-US.

I tested it from Texas and it did ok on the first try.

Thank you for feedback!

Under cPanel → PHP, I would suggest enabling below modules (if already not):

  • bcmath
  • brotli
  • dom
  • eio
  • enchant
  • fileinfo
  • gd
  • grpc
  • http
  • igbinary
  • imagick
  • imap
  • zip
  • zmq
  • inotify
  • intl
  • ioncube_loader
  • json
  • lzf
  • opcache
  • mbstring
  • memcache
  • memcached
  • mysqli
  • mysqlnd
  • opcache
  • pdo
  • pdo_mysql
  • pdo_sqlite
  • phar
  • posix
  • redis
  • snmp
  • soap
  • sockets
  • sodium
  • xmlreader
  • xmlrpc
  • xmlwriter
  • xsl

Furthermore, under cPanel → PHP → Options, I would check if I can set the values as follows:

memory_limit = 256M
max_execution_time = 300
max_input_time = 1000
max_input_vars = 5000 or 7000
post_max_size = 64M
upload_max_filesize = 32M

At Cloudflare, try to enable Rocket Loader option and test few more times.

Excellent :+1:

Otherwise, Themify might have some “page cache” top setup, but I am not familiar with this vendor / theme developer and do not know what and where to configure it. If interested, kindly try to search a bit if theme has got some settings.

Nevertheless, you could try to install some caching plugin for webpage html cache like WP Super Cache:

If not, then maybe to consider testing for a week or longer, using Cloudflare APO for WordPress (but requires Pro plan) to see if anything better.

Of course, if interested and if possible. Not required to follow all my suggestions.

All of the measures are green… Nothing I see to explain 20 second load times. when the site has not been accessed in a few hours.

I agree. I think it’s a test issue, not a real-world performance problem.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.