Slow/Unstable/Unusable Zero Trust Tunne;

I have Cloudflare installed on a device that is connected to a mobile network (3G / 4G). The internet connection at the server is fine, but my connection over the Zero Trust tunnel is very unstable and not usable. I’ve tried using different SIM cards (from different operators), but it made no difference. I’m trying to share the private network using the Cloudflare Zero Trust tunnel. My current test is to see if I can access the router’s homepage, but it is not loading. This worked perfectly before, but it has been like this for 2-3 weeks now.

When I stream the logs on Cloudflare I’m getting TCP time-out errors. The other logs do not seem to be very helpful.

When it times out I’m getting an “HTTP Response Code: 502”.
Screenshot 2024-04-15 at 14.10.37

The cloudflared daemon logs contains the following:
{
“connIndex”: 2,
“originService”: “warp-routing”,
“flowID”: “9b0afd41-6135-43a5-953d-4a6460de28fe”,
“destAddr”: “192.168.100.1:80”,
“error”: “dial tcp 192.168.100.1:80: i/o timeout”
}