Slow response for Proxing DNS websites

I have a few websites hosted on Cloudflare Pages and Workers. All of them are loading very slow when dns is proxied through Cloudflare.

To even test it out I have setup a simple static website with an image and a webpage on Cloudflare Pages, add three custom domains to it - cf.launch.watch and ncf.launch.watch and launch.watch

cf.launch.watch subdomain is proxied dns through cloudflare while ncf.launch.watch and launch.watch are direct using DNS only setting without proxied dns.

The Pages website is launch-watch.pages.dev

The cf.launch.watch (the one proxied through DNS) is taking too much time to load each time (taking almost 2-4 seconds), while the others are working fine and loads in milliseconds.

To further check and investigate, I have checked the response headers on all of them, the ncf.launch.watch, launch.watch (both with DNS only setting) and even launch-watch.pages.dev are being served from Mumbai, India Cf-Ray: 8047b080f9ad8b0f-BOM

While for the cf.launch.watch (proxied one) it’s sometimes from Frankfurt, Germany - (FRA) or sometimes from Marseille, France Cf-Ray: 8047af922c9d1224-MRS

I have even checked the /cdn-cgi/trace route for all of them. It says the same thing as I mentioned.

fl=215f74
h=launch.watch
ip=2405:201:3034:845:7c18:93aa:ad5f:90a1
ts=1694349441.588
visit_scheme=https
uag=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36
colo=BOM
sliver=none
http=http/3
loc=IN
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off
rbi=off
kex=X25519
fl=49f92
h=cf.launch.watch
ip=2405:201:3034:845:7c18:93aa:ad5f:90a1
ts=1694349461.964
visit_scheme=https
uag=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36
colo=MRS
sliver=none
http=http/3
loc=IN
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off
rbi=off
kex=X25519
fl=215f74
h=launch-watch.pages.dev
ip=2405:201:3034:845:7c18:93aa:ad5f:90a1
ts=1694349484.925
visit_scheme=https
uag=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/116.0.0.0 Safari/537.36
colo=BOM
sliver=none
http=http/2
loc=IN
tls=TLSv1.3
sni=plaintext
warp=off
gateway=off
rbi=off
kex=X25519

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.