Slow performance with large uncached file via Cloudflare

Hi All,

I’m running a Nginx web server in a Docker container on a VPS hosted at Hetzner Cloud.
The VPS has a symmetric 600mbit/s connection.
When running my website through CloudFlare, the performance is lacking. Tested with a 1GB test file, which downloads at ~3MB/s when CloudFlare proxy is turned on.
When I turn off the CloudFlare proxy the performance is as I’d expect, maxing out my home connection while downloading the same 1GB test file.

Any ideas what’s going on here? Does Hetzner have bad peering with CloudFlare?

Downloads seem to be capped at 3MB/s, no matter what network I test from.

1 Like

The site maybe lagging for the following reasons

  1. There is higher than normal traffic (this can sometimes trigger a 522 connection timed out error)
  2. Many process are being preformed at once (this could be on your browser, or on your site)
  3. Cloudflare is experiencing a service disruption or service outage (check cloudflare status at https://www.cloudflarestatus.com)
  4. Your site has too many cookies (this would be an issue with your browser)
  5. Background apps or other tabs are using up a high level of hardware (this would be an issue with your browser as well!)
    Those are basic causes, if those aren’t it (or you don’t think so) let me know!

Thanks for your input!

  1. Checked with the docker-stats comment, traffic is basically zero when the test is being performed.
  2. PC is idling when the test is running, the CPU usage of the server is also below 1%.
  3. All seems healthy in my region!
  4. I’m just downloading a 1GB.bin testfile, not visiting a actual webpage. Only testing throughput.
  5. See number 4, PC is sitting on it’s ■■■ :grinning:

How are you testing the download? Through your own internet connection?

That could explain the performance issue, you are downloading the file right? And a file of that size and take several minutes to download

Explains that too!

I’ve just set-up the same thing, I tested from a dedicated host in the Netherlands to Hezner, 114MB/s without CF, and through CF (non-cached), I achieved 47.4MB/s

Tested on my own internet connection, my work’s connection (gigabit) and a DigitalOcean VPS. Same result.

Yup, downloading a file from the webserver. But the file is only one gigabyte, shouldn’t take too long to download. My home connection is 200mbit/s. Also tested the 1GB download on a DigitalOcean VPS. Same slow speeds.

Then something is definitely wrong with my setup. I also tested from the Netherlands (Home connection, work connection, digitalocean VPS), all with the same result.

Test mine if you’d like, it’s running nginx on Debian 11

http://88.198.46.180/1GB.zip
https://hetzner-test.obscenegaming.net/1GB.zip

That’s an interesting comparison. Not great through Cloudflare, but not horrible.

1 Like

Seems a lot faster than mine.
https://f.koningnet.nl/1GB.bin

Even went as far as creating a new cloudflare account and migrating my site to that (To reset all settings to their defaults), still the same result.

Oh, that’s dreadful performance. And easily reproducible. Can you open a ticket (support AT cloudflare DOT com) and post the ticket number here? They should be able to see what’s going on with the download speed.

But if your site is full of large binary files, that could trigger some action by Cloudflare for violating ToS 2.8.

yeah looks quite slow through yours;

It’s probably something to do with how you’ve configured TCP on your server, have you changed any TCP settings? What OS is it running? What webserver are you running?

Nope. All TCP settings are on their defaults. The OS is Debian 10. The webserver is Nginx running as a docker container.

I opened at ticket by emailing to support AT cloudflare DOT com. Immediately got a automatic response telling me Email support is not available for customers on my plan type. I am on the free plan btw. Guess I’m SoL.

Only if you don’t follow directions:

Sorry, read your message to fast.
Ticket number: [#2244312]

1 Like

Because this file is larger than the maximum cached file size for your plan (512Mb) we will stream the response from your origin, which means it will be slow:

You’ll need to upgrade your plan to have 1GB files cached on Cloudflare.

1 Like

@mkoning9747 one thing - can you set a page rule for https://f.koningnet.nl/1GB.bin and set it to bypass the cache? I don’t think the other tests done with other origins & zones are comparable here - so lets try this to see if it changes things.

1 Like