Slow downloads from Hetzner Server

Hi all,

I have spoken to Hetzner and they claim the issue isn’t on there end because the issues are at the last hop. I am getting significant ping drops and slow speeds from CloudFlares network. This only seems to affect sites behind Cloudflare and these work fine from my home/work. The server is hosted in Finland. Please see the MTR/Pings/Screenshots below.

root@fi01 ~ # mtr -s 100 -r -c 200 -4 api[.]papermc[.]io
Start: 2024-04-23T18:19:47+0200
HOST: fi01 Loss% Snt Last Avg Best Wrst StDev
1.|-- static.1.114.27.37.client 0.0% 200 0.6 2.2 0.3 25.4 4.7
2.|-- core32.hel1.hetzner.com 0.0% 200 0.3 0.3 0.2 0.5 0.1
3.|-- juniper4.dc1.hel1.hetzner 0.0% 200 0.4 0.7 0.3 14.2 1.6
4.|-- static.213-133-121-234.cl 0.0% 200 1.1 6.7 0.7 74.3 12.7
5.|-- 172.67.72.198 39.5% 200 58.6 67.2 16.2 108.8 10.0
Start: 2024-04-23T18:23:11+0200

root@fi01 ~ # mtr -s 100 -r -c 200 -4 ci[.]viaversion[.]com
HOST: fi01 Loss% Snt Last Avg Best Wrst StDev
1.|-- static.1.114.27.37.client 0.0% 200 0.3 2.9 0.2 26.4 5.9
2.|-- core31.hel1.hetzner.com 0.0% 200 0.3 0.3 0.3 4.9 0.3
3.|-- juniper4.dc1.hel1.hetzner 0.0% 200 1.9 3.0 0.3 34.1 6.1
4.|-- static.213-133-121-234.cl 0.0% 200 0.7 6.5 0.7 72.9 10.7
5.|-- 172.67.68.45 47.0% 200 67.7 62.1 9.8 78.4 10.1

Example #1 - https://ci.viaversion.com/job/ViaVersion/lastSuccessfulBuild/artifact/build/libs/ViaVersion-4.9.4-SNAPSHOT.jar (3.8MB)
Example #2 - https://api.papermc.io/v2/projects/paper/versions/1.20.4/builds/493/downloads/paper-1.20.4-493.jar (42MB)

Hetzner:
— api[.]papermc[.]io ping statistics —
50 packets transmitted, 30 received, 40% packet loss, time 49413ms
rtt min/avg/max/mdev = 34.984/66.317/86.105/7.810 ms

My Home residential network
— api[.]papermc[.]io ping statistics —
50 packets transmitted, 50 received, 0% packet loss, time 55622ms
rtt min/avg/max/mdev = 6.709/8.804/22.148/3.062 ms

1 Like

Same as Timeouts in Server-to-Server Requests from Hetzner to Cloudflare Hosted Sit

1 Like

Yep, this is the EXACT same issue. I am going to try raise with Cloudflare Support

1 Like

@dev.publishing I have raised a ticket with this issue and linked your post also
#3238182

1 Like

Same issue here :frowning:

Can you provide MTR logs! Thank you :slight_smile:

Same issue here. If somebody had solved the problem, please kindly share the solution. Thanks!

This appears to be resolved:

Sadly, in Asia, the problem persist. And it looks like not because cloudflare. Maube routing/cabling problem?

There’s discussion on reddit and elsewhere that connecting to hetzner from Asia is still slow. I’ve tried to download my data hosted on hetzner, and the download speed range from ~7 - 35kbps.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.