Slow download speed (with proxy) Normal speed (without proxy)

Hi! i’m having random problems with a few files that are from cloudflare (using the “cache everything option”)

This file never fully downloads.It starts ok, but then it goes down to a crawl.

This is the headers that i get:

HTTP/2 200
date: Tue, 05 Oct 2021 17:34:28 GMT
content-type: video/mp4
content-length: 43770302
x-amz-id-2: HjQH52gss2GvEJelscVQBCEVPFM6nbkBzWaciPenmSuCerEgU/P1aMSCyTdM3g2dqJduaHVS3uo=
x-amz-request-id: B5EPSGZF3Z9XGR73
last-modified: Thu, 26 Nov 2020 06:24:35 GMT
etag: “842a8cf66a763bdbecc3bb0851d55759-6”
access-control-allow-origin: *
access-control-allow-methods: GET, POST, OPTIONS
access-control-allow-headers: DNT,X-CustomHeader,Keep-Alive,User-Agent,X-Requested-With,If-Modified-Since,Cache-Control,Content-Type
cache-control: max-age=86400
cf-cache-status: HIT
age: 407
accept-ranges: bytes
expect-ct: max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct
server: cloudflare
cf-ray: 699866a17fec089b-CDG
alt-svc: h3=":443"; ma=86400, h3-29=":443"; ma=86400, h3-28=":443"; ma=86400, h3-27=":443"; ma=86400

This is the same link, but without cloudflare: https://static.eclass.cl/files/materiales/0/2020/11/711Aplicarestilosdecelda_2.mp4

Also, using the toubled link with the diagnostic tool (Diagnostic Center | Check SSL and Test Website Security | Cloudflare), it never returns anything, it just hangs

I believe 43.7MB for a video needs to download first at the end-user, despite the fact of their Internet speed connection.

Watch out to not get in trouble with Terms of Service if you are serving even larger files than this one.

Not to mention, mobile users and the time needed to download it, even for desktop users as a whole file, rather than as a separated chunks of a file.

May I ask are you using some Cloudflare Page Rules too with Cache Level: Cache Everything option being selected?

May I also ask is this being served “as-is” or through the Cloudflare Stream service?

Hi! thanks for yout reply!

My concern lies in that when using the second link (the one that doesn’t uses cloudflare’s cdn) it downloads without issues, while the one using cloudflare’s cdn, eventually the download simply stalls.

This is the pagerule for cdn.eclass.com

We’re not using Cloudflare Stream, it’s just as if it’s a regular file.

Also, this just started happening about two days ago. Before this, it was working fine. We’ve already tried clearing the cache to no avail.

Also! I’m from Chile and according to the cf-ray, i’m getting responses from CDG (paris, france) or LHR (london, UK), without using a VPN

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.