Slove Response frome some countries in Eastern Europe

speed

#1

Hello, today we noticed the server’s protracted response to the request for uncached pages, sometimes processing reaches more than 15 seconds. For example https://www.gearshout.net/?s=knife


#2

Can you post the output of https://www.gearshout.net/cdn-cgi/trace?

Also, your screenshot didnt upload.


#3

fl=132f64
h=www.gearshout.net
ip=178.95.171.194
ts=1546606629.169
visit_scheme=https
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36
colo=KBP
http=h2
loc=UA
tls=TLSv1.3
sni=plaintext


#5

Just checked it, it is not an issue of your PoP but your site generally appears to load relatively slow. For me and also at http://sitemeer.com/#https://www.gearshout.net.

Just for clarification, does it always take a minute to load or only occasionally?

Thats something you need to check on your server. Of course it is Wordpress :smile: but you will find plenty of solutions to optimise such a setup here as well as on other forums in general, just use the search.


#6

We have already contacted our hosting, they argue there are no delays on their side. Usually the site loads in 0.5-3 seconds. Today we noticed a delay in loading. No changes were made on the site.


#7

Hosts often say so and in a scientifically determined approximation they are wrong in 83.4627% of cases :wink:

Again, does it always take a minute or just that one time?

Can you check if http://sitemeer.com/cdn-cgi/trace also goes via Kiev and if the site (on the root path) also takes a lot of time to load?


#8

fl=87f104
h=sitemeer.com
ip=178.95.171.194
ts=1546612107.564
visit_scheme=http
uag=Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/71.0.3578.98 Safari/537.36
colo=DME
http=http/1.1
loc=UA
tls=off
sni=off


#9

Usually site loads in 0.5-3 seconds. I see big delays only on non-cacheable pages.


#10


#12

Alright, managed to debug it a bit more. The issue does not seem to be the s parameter but - as you mentioned - some caching. Not Cloudflare’s caching though (you dont seem to cache the main site) but some caching on your server (or some proxy inbetween; you seem to have Varnish in place). The moment you append any data to the query string the loading time appears to go up.

I am afraid this will require some good old debugging of your server/application/code.


#13

I might have to eat my own words.

Something seems a bit off here and I cant pinpoint it yet. Assuming your server’s IP ends in 16 it really does seem as if requests via Cloudflare take more time compared to going directly to the origin. It might even have something to do with the sent HTTP headers, as I have difficulties reproducing it with a regular cURL call. The fact that some caching is involved does not make it easier. Or, I am completely off-course :smile:.

More on it if I manage to reach the end of that rabbit hole :confused:


#14

Now everything seems back to normal. Also, we did not see slowdowns when entering the site through a proxy. In addition, Error 503 sometimes occurred.


#15

Everything back to normal? So I can stow my debug arsenal? :smile:

Good :+1:


#16

Most likely the problem was with the Scheduled Post Trigger plugin. After it was turned off, we didn’t clean the cache. Now the entire cache is updated, and everything works flawlessly.