Sites have a chance of getting a white screen

My site is deployed on Cloudflare Workers, using my own domain name sciadv.top, but recently I occasionally get a white screen when I access it, without any error message, and the source code is empty.

Because I need Non-ASCII URL, so I used kv4cf to replace the original kv-asset-handler. but I guess this is not the main cause of the problem.

There are no errors when accessing with the Workers.dev domain.

The Hexo source code is here

The Hexo generated site content is here

Workers related content is included in the Hexo repository.

After my test, this problem still exists after canceling Workers and using CNAME to Github Pages, so I can rule out the problem of Workers.
Is there a problem with my site settings?

English is not my native language so I use translation software, if you can’t understand please ask again.

1 Like

I have read similar questions in the community. Set up Page Rules, Disable Apps, Performance, and Security.
But the problem is still there.

This is interesting… After a while the site was available again.
Is this a rate limiting method…?

¡Hola @mcseekeri!

Happy :taco: Tuesday!

I tested the page over at WebPageTest Test Result - Stockholm : sciadv.top - 08/17/21 21:14:44 and it seemed to have loaded fine every time.

You might want to review https://developers.cloudflare.com/workers/platform/limits and https://developers.cloudflare.com/workers/learning/metrics-and-analytics to look for any issues.

You might also want to inspect the output of https://developers.cloudflare.com/workers/cli-wrangler/commands#tail for any exceptions.

Hope this is useful.

¡Gracias!

Thanks for the help… I also used WebPageTest to access the test, and every time it works.
But I changed the way… Quickly click on the link in the site and then jump, so after a few more times there will be a white screen…
Is this an anti-DDOS measure of Cloudflare Workers Free…?

In addition CNAME to Github Pages seems to be no problem, that is, the speed will be much slower than Workers.

When the response is empty (no source code), are you still getting an HTTP 200 status code?

Yep.
It’s a bit strange…

I have similar issue with my react spa site (also hosted on workers). And I catch white screen on your site.
This issue related to the browser cache so if you disable cache in browser (“disable cache” checkbox at google chrome dev console on the network tab) - site will work.
I think that this issue on the Cloudflare side - because we did not change anything on our side and earlier our site works correctly, but Cloudflare support ignore my ticket.
I found temporary solution by disabling cache on the workers level (check GitHub - cloudflare/kv-asset-handler: Routes requests to KV assets) but this is awfully.

@mcseekeri @vlad8 - I’m not able to look into this much further at the moment. If you are interested, I would suggest looking at the source of the worker that is used for the Site project: GitHub - cloudflare/worker-sites-template

Maybe there is something that could be handled better when an asset is empty/not found (based on the read from KV) or generally handling some unexpected failure.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.