Sitemap.xml not resolving

Hi

My sitemap is not resolving and I cannot work out why.

I have purged the Cloudflare cache for the https://procutsouth.co.nz/sitemap.xmlsitemap.xml

My sitemap works when I turn on Cloudflares Development mode, but turn off Development mode and the browser just sits there saying ‘tranferring data from https://procutsouth.co.nz…’

Is there anything in particular I need to do for Sitemaps? I could not find anything when I searched.

Thanks in advance

It does resolve to me. I can open it.

Moreover, the correct URL is https://procutsouth.co.nz/sitemap.xml.

If it takes some time to load, does it re-generate the sitemap on each request? (which can be related to hosting performance)

Maybe you do not need to purge that sitemap index, rather the inner sitemap files?

Do you use some caching plugin for your WordPress Website?

Hi
Thanks for checking - I had the Development mode on (sorry I forgot to switch it back off). Dev mode is now off

Sorry, for the copy/paste error in the url.

The Sitemap was created today and is re-generated only whenever there is a new post.

It is not a caching issue, I have deleted the Cloudflare cache for the site after generating the sitemap. I use WP Cache and also have deleted the cache there.

I have tried from my phone to definitely rule out caching on this PC

Thanks for your help

May I ask what is the issue then? Are you sure it is related to Cloudflare?

Hi

the problem is

  • with Development mode on, ie by-passing Cloudflare, the site map loads
  • with Development mode off, the site map does not load

To try to get the sitemap to load I did the following

  • I delete the Cloudflare cache
  • deleted the plugin cache
  • deleted my browser cache
  • tried different browsers
  • tested on other devices to rule out caching on the device I was using
  • finally turned CF Development mode on, by passing CF, and the sitemap loaded

The rest of the site is working fine through Cloudflare without Development mode.

Thanks

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.