Site works but Error 522 Connection Timeout with Cloudflare


#1

I have an ipv6 only site qa.im, it simply 301 redirects qa.im to www.qa.im

Here it is with Cloudflare disabled:

# curl qa.im --verbose                                                                                                                 
* Rebuilt URL to: qa.im/                                                                                                                                   
*   Trying 2001:470:1f05:fd0:1ce:c01d:c0:ffee...                                                                                                           
* Connected to qa.im (2001:470:1f05:fd0:1ce:c01d:c0:ffee) port 80 (#0)                                                                                     
> GET / HTTP/1.1                                                                                                                                           
> Host: qa.im                                                                                                                                              
> User-Agent: curl/7.47.0                                                                                                                                  
> Accept: */*                                                                                                                                              
>                                                                                                                                                          
< HTTP/1.1 301 Moved Permanently                                                                                                                           
< Server: nginx/1.13.7                                                                                                                                     
< Date: Wed, 13 Dec 2017 08:13:44 GMT                                                                                                                      
< Content-Type: text/html                                                                                                                                  
< Content-Length: 185                                                                                                                                      
< Connection: keep-alive                                                                                                                                   
< Location: http://www.qa.im/                                                                                                                              
< Expires: Thu, 14 Dec 2017 08:13:44 GMT                                                                                                                   
< Cache-Control: max-age=86400                                                                                                                             
< Pragma: public                                                                                                                                           
< Cache-Control: public                                                                                                                                             
<                                                                                                                                                          
<html>                                                                                                                                                     
<head><title>301 Moved Permanently</title></head>                                                                                                          
<body bgcolor="white">                                                                                                                                     
<center><h1>301 Moved Permanently</h1></center>                                                                                                            
<hr><center>nginx/1.13.7</center>                                                                                                                          
</body>                                                                                                                                                    
</html>                                                                                                                                                    
* Connection #0 to host qa.im left intact

As seen above, it is working correctly with direct access. However, as soon as I enable cloudflare, it times out after 15 seconds and returns 522 Connection Timeout error, sometimes 502 Bad Gateway. I tried curl with and without Cloudflare enabled from multiple servers and experienced the same results.

I’ve read https://support.cloudflare.com/hc/en-us/articles/200171906-Error-522-Connection-timed-out and I don’t think my situation fits in the two scenarios

Please let me know what I am doing wrong : ) .

Thank you in advance!
W


#2

Sorry for the delay. Are you still having issues? Have you submitted a support ticket yet?

If you have tried both scenarios from the KB article, it’s probably time for the support team to assist.