Site won't load without WWW

Hi there. Can someone help me? I can’t get my URL to connect to wendybrandmentor.com, but it will see the site when I use the www - I don’t know if this will alert me if someone answers but if not can you please email me at [removed by mods for security].

Thank you

It is likely related to your DNS settings in your account. Have you looked at this other thread?

It looks like your server isn’t configured to respond to non-www.

  1. It would be nice if your server was configured to respond to just wendybrandmentor.com, but not that desirable. Your website should only show up as one or the other. So let’s just stick with the www version.
  2. Use Page Rules at Cloudflare to redirect any non-www request to the www URL. Page rule URL should match: https://wendybrandmentor.com/* and then 301 Redirect to https://www.wendybrandmentor.com/$1 (the * and the $1 will retain any path the visitor types in.

You may notice I specified HTTPS for both. This is much preferred over HTTP…so make sure you go to the Cloudflare SSL/TLS app and enable: Always use HTTPS. Otherwise the rule won’t kick in if your site is running HTTP. Besides…all the cool kids run HTTPS.

1 Like

Both don’t seem to be working on my side.

1 Like

Your domain appears to be configured in a partial/CNAME setup from a partner. At the moment neither the root nor www is going through Cloudflare and both pages present with an invalid SSL certificate.

When a domain is in a CNAME setup it typicaly has a record which looks like foo.example.comCNAMEfoo.example.com.cdn.Cloudflare.net and this is set and managed by the partner. Usually the partner config doesn’t support the root domain out of the box because most DNS providers can’t CNAME at the root of a domain. I would recommend contacting the partner you signed up through.

Hi, I looked everywhere for the answer and finally got my site redirecting properly thru the www url.

All you gotta do is go to your Cloudflare dashboard and click where it says “Page Rules” where all the blue square buttons are, then click on “Create Page Rule” and enter “www.yourdomain.com/" with the star "” thing at the end, and select “Forwarding URL” from the drop down menu.

Also select “301 Permanent Redirect” from the dropdown option, and where it says Enter Destination URL simply type “https://yourdomain.com” without the www, then click “Save & Deploy” and you’re done!

Check your site and see if is fixed, if within 5 to 15 minutes it doesn’t redirect correctly then go back to your dashboard and click where it says DNS, then click on Add Record, the “A” Type will already be selected, on the Name write this “www” (without the quote " " symbols obviously), then under the IPv4 address you need to type your hosting provider’s IP, contact them to get it. Or use Cloudflare’s they have their IP somewhere in the support pages.

In my case I’m using GroovePages to create my site, Cloudflare is their host provider. So this number is GroovePages’ IP “35.227.253.8”.

That’s putty much it. You’re done. :slight_smile:

2 Likes

This worked for me, thanks