Site will work without "www" but won't work with "www"

Our DNS records recently were changed, so now we have a CNAME/www/@ to direct people from to However, we are only able to achieve this when the proxy is not enabled. When it is enabled, we still experience the same error.

Most of the online help we look into states that it could take up to 72 hours to see changes made to the site, is this true? Is there anything we could do to speed up the process?

Any help would be greatly appreciated.

May I ask what is the error code or message?
Can you share a screenshot of it?

This is the error page that we see when accessing the website through “

This looks to me as not a Cloudflare error page, rather from the provider/hosting.

May I ask if you are using some 3rd-party integrator or SaaS for your website?

Can you share a domain name?

Furthermore, you aren’t using any of the Page Rulest at Cloudflare to redirect from www to non-www (or vice-versa) yet, right?

I still fairly new to Cloudflare so I will answer to the best of my ability. Our site is on WordPress, hosted through Cloudflare. Our domain is registered under

I don’t think we are currently using the Page Rulest at Cloudflare.

All you need would be this:
Setting: Forwarding URL (301) to$1

Just like that and your ‘www’ problem should be fixed.


Here is what I added to the page rules and it still did not seem to work.

It looks like your site is on Hubspot. Has it always been on Hubspot?

It looks like something is interfering with your Cloudflare settings.

Does Hubspot have a Cloudflare settings option that you used?

We do use Hubspot and had to verify the domain in DNS to connect them. Would it be worth trying to disconnect Hubspot to see if it resolves the issue?

That probably won’t help, as your site might no longer work. Have you asked them if they can do the redirect?

Disconnecting from Hubspot appears to have fixed the website problem. It looks like Hubspot was trying to host the www domain instead of simply connecting to it. Thank you for mentioning HubSpot, we were able to address the issue.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.