Site still "not secure"

DNS nameservers are already pointing to cloudflare from original host. Site is already active on Cloudflare. “Always use https” is applied. Site still says “not secure.” What could be wrong?

Thanks in advance!

Could you post the domain?

Sure.
Domain is:
http://networkmarketingfundamentals.com/

I’m seeing a 526 error, which means your server does not have a valid SSL certificate for your domain. You can either have your host fix this (this is better), or try setting your SSL mode here to Full (not strict).

Okay that helped a lot and I got the SSL certificate for my domain from my host.

Thanks for alerting me to that problem!

Now I am seeing that the https version of the domain is working perfectly. Got the lock symbol in the address bar.

However, the http version of the domain still loads, and shows up of course, as “not secure.”

Wondering why this might be going on…

Again thanks so much for the help!

1 Like

If I try going to the http version I get properly redirect to HTTPS. You might have the old records cached in your browser/DNS cache, in which you should.clear the DNS cache or try on a different system.

Also, your www has the same issue https://www.networkmarketingfundamentals.com/. I’d recommend implementing the www -> root redirect from Redirecting www to non www.

1 Like

Okay I have been working with this for awhile and can’t get it figured out.

My site is totally fine when I enter the domain with “https”. The little lock is there and everything.

But when I enter it as the raw domain, or even with www, it jumps to the “http” version of the domain, and says “not secure” in the address bar.

Any idea what it could be?

Thanks in advance.

I’m on mobile right now so can’t dig deep, but http forwards me to https and it’s secure.

In the SSL/TLS -> Edge certificates,section, I expect that Always Use HTTPS is enabled. That’s how Cloudflare redirects to HTTPS.

Yes, I see it’s working now. Perfectly. Thank you so much.

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.