Site shows up as https and non-secure

ssl

#1

Hi,

I have a new site which I have just added CF SSL to, along with the “Cloudflare Flexible SSL” plugin.

I also have the “Always use HTTPS” and “Automatic HTTPS Rewrites” turned on under the “Crypto” tab.

Initially, the site was showing “https” correctly with the padlock, but now it is showing “https” with the non-sucure icon although I haven’t made any changes to the website.

Can you please advise as to what could cause this?

The website is: https://fullcirclejourney.com/

Thanks,
Rose


#2

You have mixed content issues…

I believe they are backgrounds in the CSS files.


#3

Your page is loading insecure content though I get redirected to HTTPS when I open the JPEGs directly.
The HTTP header shows a “301” (moved permanently) which is caused by the “automatic redirects”. Try to fix the links this could solve your issue.

image


#4

I loaded the plugin “Cloudflare Flexible SSL” because I thought this was supposed to fix both the SSL Redirect Loop, AND the non-secure items (jpg file folders). It worked initially, but has now reverted back to a non-secure page.

If I do need to change those items you’ve listed, can you tell me how I can access the source code to do so.

Thanks,
Rose


#5

Cloudflare Flexible SSL is not a plugin and will not solve these issue as they are due to the link being HTTP in the source code. The following redirect to HTTPS on those link does not count.

This we cannot tell you, the origin is under your control, we (not as Cloudflare) do not know anything about it. You could try enabling the HTTPS Everywhere option, but I do not think will solve your issues.


#6

This topic was automatically closed after 14 days. New replies are no longer allowed.