Site shows as SSL everywhere except on my work network!

#1

I set up my work’s site a few days ago with basic SSL, and it shows as secure pretty much anywhere but on my network at work.

I have posted my diagnosis link below- everything comes back clean.

https://www.whynopadlock.com/results/bf7ca4a0-17d9-4fb3-812d-7678b1e73715

I’d like to move to a paid version, but I need to be able to show my boss that little padlock to get him to buy in.

0 Likes

#2

Have you tried clearing your cache / using incognito / inprivate browsing window?

0 Likes

#3

I have cleared cache, flushed DNS, tried incognito mode, all show ‘not secure’.

If I take this same laptop to Panera, or home, or log in from a VPN tunnel to an outside location, it shows as secure.

0 Likes

#4

Do you have access to clear the router cache (or anything else on the network that may be caching it)?

0 Likes

#5

Are you running split brain DNS internally? What IP address is returned for the site if you do a dig or nslookup for it? Compare that to the IP you get outside.

2 Likes

#6

I will look into that- I have access in that I am allowed to, but not in that I have the credentials to in front of me. Thanks for the suggestion!

1 Like

#7

I will try to find out. Thanks for the suggestions.

0 Likes

closed #8

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

0 Likes