'site redirected you too many times' error in Wordpress customizer using proxy

Has anyone faced the issue for when you proxy your A records in Cloudflare, it creates a redirect error in the Wordpress customize screen? If I turn proxy off, then it loads fine. The rest of the site loads normally. I’ve tried changing SSL settings in CF to full and flexible, but it wasn’t a fix. My host had no answers other than to turn proxy off in CF. But ideally, that’s one reason to actually use CF, to mask your IP. There’s got to be a simple solution here!

Have you tried this guide:

Yes, thanks… unfortunately it didn’t resolve the issue.

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue with your WordPress website.

Before moving to Cloudflare, was your Website working over HTTPS connection?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding SSL settings at the SSL/TLS tab on Cloudflare dashboard:

If yes, can you double-check if you have a valid SSL certificate installed at your origin host / server from your web hosting provider (should cover both your naked (root) domain any other needed sub-domain like www, mail, etc.)?

Is your WordPress configured in the “Options” menu for “base” and “home” url with HTTPS or without like HTTP? :thinking:

Is your WordPress Admin dashboard configured to work with the SSL?

Do you access your Website with www or without it?

Have you tried using below plugin?

Maybe you’d need to check and fix .htaccess file for HTTPS.

May I ask of the “Automatic HTTPS Rewrites” and “Always Use HTTPS” options are enabled if you navigate to the Cloudflare dashboard → SSL → Edge Certificates? :thinking:

Sharing few of my post, hope it helps you a bit:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.