Site performance much worse with Cloudflare

Recently, my website began experiencing loading issues, despite paying for Wordpress Optimization, and even having a rule to cache everything.

I turned off RocketLoader which helped with some content that wasn’t loading, but not with multiple pages getting completely stuck trying to load. I have a very fast internet connection (900+ Mbps), and a simple website, so this is abnormal.

My site is built using Semplice in Single Page App mode, in case that’s relevant.

When the pages get stuck loading, I see this error in the console: Failed to load resource: the server responded with a status of 403 ().

I followed the instructions here to try turning off Cloudflare: and immediately, the loading problems are resolved.

Should I just give up on Cloudflare? I thought it was supposed to improve performance. Is there a way to determine which aspect of Cloudflare cause the performance issues?

Thanks in advance for any help.


  1. Visit your website and perform the action that would normally result in a request being blocked with a 403;
  2. Wait a few minutes;
  3. Go to Dashboard > Security > Events. If the request was in fact blocked by Cloudflare, you should find an event related to that block action. Depending on your site traffic, you may need to filter by IP address, User Agent, URI Path, etc. to find it. Check the “Service” that blocked it.;
  4. If this was
    a) Bot Fight Mode, disable this feature.
    b) Super Block Fight Mode, create a WAF Custom Rule to Skip it for the specific situation, with relevant conditions such as the URI Path and the visitor’s IP, for example;
    c) WAF Managed Rule, you need to create a WAF Exception for that rule. See: Add a WAF exception in the dashboard · Cloudflare Web Application Firewall (WAF) docs
    d) WAF Custom Rule, you need to edit it accordingly.

When I re-enable Cloudflare and perform the actions which result in 403 errors, nothing shows up under “Firewall Events” in Cloudflare.

Is there any way to determine why my site’s performance is now so much worse with Cloudflare enabled?

I guess I should just keep Cloudflare disabled and stop paying the $5 for for Wordpress Optimization?

Ironically, it appears that Cloudflare’s “Automatic Platform Optimization for WordPress” is the culprit which is causing the performance issues. I just tried toggling it off in Cloudflare, purging the cache again (and clearing my browser cache again) and now the loading issues no longer occur.

Is there any way I can officially report this, since the feature is doing the opposite of what it’s supposed to do?

That means your origin, not Cloudflare, is blocking those requests with a 403. Make sure your origin restores visitor’s IP so that it doesn’t rate-limit Cloudflare IPs.

Restoring original visitor IPs · Cloudflare Support docs

Your description of the issue is too vague. You need to familiarize yourself with how Cloudflare works, and especially how Cloudflare Cache works, starting with Default Cache Behavior and how APO for WordPress works, and report back here your findings, with specific details, such as headers returned, your Cloudflare and your origin caching configuration etc.

1 Like

mod_remoteip is already installed on all Nixihost shared servers, and they confirmed that Cloudflare proxy IPs are already defined in their Apache config, so I don’t think rate-limiting is the issue.

Maybe it’s something about Cloudflare’s APO that doesn’t mesh well with Semplice, specifically.

At any rate, since it breaks my site, I am just going to keep it turned off, and stop spending $5 a month on this feature.

1 Like