Site offline with too many redirects

Hi folks, I made a small mistake on a version which caused the main page of my site to be unresponsive. Luckily that was a DB error and just fixing the database fixed the problem.
Then I noticed a pop up on my browser about cloudfare saying the website was offline.
I look into the logs of the server and all seemed to be loading
To my surprise the site was being processed by the server, but all static assets (css, js, images) that were cached by cloudfare were throwing the too many redirects
I tried to purge the cache … no luck
To my surprise, opening a new browser in incognito I can access the site, but not on my regular browser session.

Any suggestions?



Thank you for asking.

May I ask what kind of suggested steps for troubleshooting have you already tried as written on the article from below? :thinking:

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Furthermore, before moving to Cloudflare, was your Website working over HTTPS connection?

You could determine this by:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect, then make sure site is working as expected with HTTPS without any error
  4. Check with your hosting provider / cPanel AutoSSL / Let’s Encrypt / Certbot / ACME and renew it in case if needed
  5. Only then, when your website responds over HTTPS, you should un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

May I ask you to check out what option have you got selected by navigating to the Cloudflare dashboard → Caching → Configuration → find section “Browser Cache TTL” and make sure the selected option from the dropdown menu is “Respect Existing Headers”.

Furthermore, from the same menu, click on the blue button saying “Purge Everything” to flush the cache at Cloudflare Edge, just in case.

Wait for a minute or two.

Refresh a page in your Web browser, otherwise try clearing your Web browser cache or use a different Web browser to test out again.

Some suggestions to try out:

  1. Try using a different Web browser, or ry clearing your Web browser cache
  2. Try using a Private window (Incognito mode) or a VPN connection if possible
  3. Try using your mobile phone (4G LTE, mobile data, cellular)

Thank for your very detailed answer.

Eventually the site was back to normal on my browser, the incognito and other browsers also had no issues, which was good to see. Not sure why my browser was having the issue, but glad it sorted out.

Thanks once again

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.