Site not SSL protected

hello,

my site (www.shopstores.co.uk) has suddenly stopped being a SLL protected. I have not made any changes to it and the IP address is the same.

The site IP address was 63.32.105.46 and it seems to have changed (not sure why)

Any ideas ?

The Cloudflare certificate still is in place, however you server certificate is not valid any longer. My guess would be your certificate has expired and was replaced by a self-signed certificate (which is accepted by Cloudflare only in a less secure context).

The solution would be to re-provision a new, valid certificate on your server. Most likely your host would be responsible here.

Thanks. I’ll give that a go

OK. not made any progress on this. Site is hosted on AWS and i have generated and validated a new SSL certificate.

Not sure what i’m doing wrong…

ah… it’s suddenly has started being protected. Maybe whatever i did worked.

Thank you for your advice.

You still have the same invalid certificate in place. The reason why you believe it is working now is most likely because you now hit Cloudflare’s edge with Cloudflare’s certificate. The connection to your server is still not properly secure because of the invalid certificate on your server though.

Oh… i’m confused now. should i just contact my domain hosting company ?

As I mentioned your host is most likely the right contact. You basically need a valid certificate on your server. Whoever maintains your server needs to configure that.

ok. so my site is hosted on AWS and the domain is held on ionos.co.uk.
so which one would it be ?

Amazon probably. However that is a virtual server, not regular hosting, right?

yes, it’s a virtual Ec2 server

Who is responsible for the server maintenance?

it’s me i’m afraid :slight_smile:

Then it will be you who has to configure that certificate :slight_smile:

The easiest way would be an Origin certificate from Cloudflare

I’ll give it a try

OK. i have followed the instructions as per the link.

Once in AWS there is a section for a Certificate chain.

Message: “Provided certificate is not a valid self signed. Please provide either a valid self-signed certificate or certificate chain.”

What is it that i paste in there ?

The certificate from step 4.

OK. done that.

But, i guess i need to now somehow link it to my site ?

I am not overly familiar with their configuration and how you’d configure a certificate. I am afraid that would be a question for Amazon at this point :slight_smile:

1 Like

Are you running your own ec2 instance, or are you already using cloudfront in some way/shape/form?