Site Not Seemingly Using Cloudflare

For some reason my site doesn’t appear to be utilising Cloudflare’s functions, despite the A DNS records being proxied.
My server is located in London and website location searches seem to suggest Chicago which appears to be correct when being proxied.
However:

  • Website is on Full (Strict) security but origin certificate isn’t being masked as a Cloudflare cert when checked via browser. Usually my sites show a Cloudflare certificate. Mine shows Letsencrypt.

  • Page Rule “Cache Everything” does nothing. Usually this will cache the wp-admin bar and make the site near instant. This is not the case for me.

I have CSS, JS, HTML minify all on. Cache 6 months, brotli, all the usual settings. Very concerned that none of this is taking effect.

Has anyone got any advice on this? I am using the Brett and Vita nameservers, since changing from Mitch and Sue when I switched my records between two Cloudflare accounts.

On an unrelated note, I am trying to improve my site’s First Contentful Paint. When I enable “Page Caching” , be it on WP Fastest Cache or w3 Total Cache, the site is instant to load , yet Pagespeed insights still reports the same First Contentful Paint? Literally no change whatsoever with page caching. Very bizarre.

What’s the domain?

Also, the LE certificate is perfectly fine as Cloudflare is using LE.

I have turned the cache everything rule off for now. Thanks for confirming regarding the SSL. Seems strange though as my other sites usually show “Cloudflare” as the certificate provider.

Well, if the nameservers in your account are brett and vita, then your domain is properly configured. It’s also proxied, so that should be okay as well.

Thanks, just seems strange that cache everything isn’t going anything. Cloudflare is seemingly having no performance benefit whatsoever, be it proxied or not

That should work too if you enable it.

Though you are disabling caching, so Cloudflare won’t cache the main page either.

$ curl -I https://franchise-directory.co.uk | grep control
cache-control: no-store, no-cache, must-revalidate

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.