Site not loads (timeout) when using cloudflare proxy

So I have recently encountered a problem with the Cloudflare proxy.
I have two websites one pointing to a hosting company and another having a connection to Cloudflare with tunneling with cloudflared on my home lab.

So I started today my server and checked the connection to the website I hosted on my home lab. It didn’t load, tried on my phone (I tought it was some DNS error, because I use PiHole) and still got the same ERR_CONNECTION_TIMED_OUT error. I tried to ping it didn’t work.

For some reason I decided to check out my other website (the one that I have at a hosting company). It didn’t load as well and I previously did not encounter any problems with it. I then disabled the proxying and used Cloudflare as DNS only and after some time (about 5-10 minutes) later it loaded with the hosting company’s SSL and everything.

I have tried the following:

  • Reinstalling the cloudflared container on my homelab
  • Purging the cache on Cloudflare
  • Remaking the tunnel in the Zero Trust menu
  • Rebooting multiple times my home server

I suspect the issue is with one of the following, but I have may be mistaken:

  • Cloudflare Proxy
  • Cloudflare Tunnel
  • cloudflared container

If anyone has any idea what is going on please let me know!

I’m having this issue too. Some mobile network internet providers are unable to access our website, but when they turn on a VPN, they get through.

Yeah, looks like a global thing.

What’s the domain/website?

Are others on different networks/ISPs able to reach your site?

Does https://yourwebsite.com/cdn-cgi/trace load?

Turns out, it was propably a Cloudflare issue. I waited some day and it’s working.

My tip if anyone encounters this problem I described above to just wait a few days.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.