Site not loading on Firefox

We have staging website behind Cloudflare that loads on any browser, but Firefox:
https://storate.waat.app

And production website on AWS Route53 that loads on any browser, including Firefox:
https://app.storate.io

We’re always using the same stack, also for other projects and none of them loads on Firefox.

Any hint?

Hello,

Thank you for asking.

I can confirm both links are openning and website is loading fine in my Firefox web browser :thinking:

What error are Firefox browsers getting?

It never loads and sometime it gets NS_ERROR_ABORT

To me it happens on both Mac and Linux. Our Client that was complaining was using Windows.

Hey @enrico.cerroni ,
Make all the necessary calls to nsIChannel.notificationCallbacks and cancel the request after that.

https://support.mozilla.org/en-US/questions/1245115

Yes, that is true: disabling the antivirus would make the site reachable. However, this opens a lot of more questions:

  • disabling antivirus worked on macOS
  • still not working on Linux, indeed there is nothing to disable
  • why this SSL stuff is problematic only when using Cloudflare? Other websites works just fine.
  • it’s impossible to tell the Client that the issue is related to the antivirus and that he should tell every users using Firefox to disable it :upside_down_face:

There should be a different solution. I guess Cloudflare team is aware of this issue. Any idea?

I finally found an article that explained how the issue seems to be related to the HTTP3 implementation of the browser.

Indeed, setting network.http.http3.enable to false in Firefox made it work immediately.

So what I did was to disable HTTP3 on Cloudflare Dashboard (Network)

Ref: https://www.ghacks.net/2022/01/13/some-firefox-users-report-connection-issues-workaround-inside/

I dont think that’s a good idea, disabling the anti-virus will put the computer at risk
As we all know anything on the internet is not safe.
kindly shed some light on this mate.

1 Like

A post was split to a new topic: Cpanel issue asking here