Site not available over https

#1

I thought I set up my site to use cloudflare. I wanted to use it to get SSL certs working. I updated my nameservers to the ones provided, but now I am getting “connection refused” when I try to visit “https://darajava.ie”. http still works here though. What am I doing wrong?

Thanks!

0 Likes

#2

Loads for me:

image


Although, it does look like your website has mixed content issues, and tried to initiate a ws:// connection over HTTP (this should be wss:// for secure websockets).

Mixed content is in the main request:

        <script src="http://www.youtube.com/player_api"></script>

and browserLayout.js tries to initiate ws://:

    this.connection = new WebSocket(
      'ws://' + process.env.REACT_APP_URL + ':1338?desktopClient=1&roomId=' + localStorage.getItem('room'),
    );
0 Likes

#3

Note that CF only supports certain ports. You’ll need to change 1338 to another HTTPS port that CF supports:

0 Likes

#4

Haha nice! You found the code! I was aware of the mixed content issue, however the site is still not loading for me in https. Maybe this is just a propagation issue if it’s working for you. Thanks for looking into it.

0 Likes

#5

Also, good to know about the ports. Thanks!

0 Likes

closed #6

This topic was automatically closed after 31 days. New replies are no longer allowed.

0 Likes