Site isn't working after pointing nameservers to Cloudflare trying to add SSL


#1

It appears to be redirecting to https, but I keep getting this error message below. I’ve already cleared the cookies and tried that route. I’m not sure what to do to resolve it.

This page isn’t working
firsttitlesource.com redirected you too many times.


#2

#3

Alright, I set the crypto to “full”. Now I get an Error 525. It says “Browser: working”, “Cloudflare: working”, “Host: error”.


#4

Your server is most likely not properly configured for HTTPS. Contact your host and get them to configure a certificate for your site.


#5

Well, I’m trying to use Cloudflare for the SSL. Would the hosting company still manage the certificate?


#6

You cant use Cloudflare for SSL only, you still need a certificate on your server, otherwise your site will still not be secure.


#7

This is what I signed up for here. https://www.cloudflare.com/ssl/

Then I added the site and changed the nameservers like it said to do
and since then the site hasn’t loaded.

So, what certificate are you mentioning I need to get from the web host?
The whole point of going this route was to avoid purchasing an SSL certificate
from the web host. As in the video here: https://www.youtube.com/watch?v=7zVCn-9IYws&t=602s


#8

That wont work. You still need a certificate, as otherwise - as I already mentioned - your connection would still not be encrypted. Please refer to Why we recommend you don't use flexible!

If you dont want to purchase a certificate from your host you can also get a free LetsEncrypt one and have it installed on your server. If your host does not do that I’d strongly advise to switch host.


#9

That is another one of those videos that says ‘just use flexible and it will all work’ without fully explaining. I have now posted a comment on the YouTube video enlightening the author :innocent: Doesn’t appear to be showing publicly though so they evidently don’t like it!


#10

Alright, thanks. How do i fully uninstall this Cloudflare SSL from my website. I pointed the nameservers back to the hosting defaults and removed the site from Cloudflare. Yet, its still redirecting to https.


#11

You can still use Cloudflare, you should just have a certificate on your origin server to make it fully secure.

If you have pointed it away from Cloudflare, the HTTPS redirect must be coming from your server, did you add an SSL plugin or change the default address to https?


#12

Yes i did, the really simple ssl plugin. But i deleted it using FTP


#13

I will, but first I just wanna get back to where its working again. I reinstalled that plugin using FTP and when through the deactivation instructions, so now I can log into the wordpress backend at least, but when I go to visit the site it still redirects to https.


#14

Your domain still points to Cloudflare. You can also simply pause Cloudflare in the control panel. If you plan to use it later that would be the more advisable approach than changing the nameservers.


closed #15

This topic was automatically closed after 31 days. New replies are no longer allowed.