Site is only accessible in desktop Firefox

I can only connect to my site, themannerlydog.com, through desktop Firefox, but not desktop Chrome or Safari. On mobile, I have only tried Safari and Chrome and neither can connect to my site.

From my testing below, I can see that the server successfully connects only over TLS1.3. I have set the Minimum TLS Version to 1.0. I have HSTS turned on. I have already tried disabling TLS 1.3 on my site and that does not solve the error.

I’ve got an SSL cert from Let’s Encrypt at my server and my SSL settings at Cloudflare are set to flexible.

I’m at a loss for what to do next. Does anyone have any ideas?

[kyle] ~ $ curl https://themannerlydog.com -svo /dev/null --tlsv1.0
*   Trying 167.206.37.137...
* TCP_NODELAY set
* Connected to themannerlydog.com (167.206.37.137) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/cert.pem
  CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
} [232 bytes data]
* TLSv1.2 (IN), TLS alert, close notify (512):
{ [2 bytes data]
* error:140043E8:SSL routines:CONNECT_CR_SRVR_HELLO:reason(1000)
* Closing connection 0
[kyle] ~ $ curl https://themannerlydog.com -svo /dev/null --tlsv1.1
*   Trying 167.206.37.137...
* TCP_NODELAY set
* Connected to themannerlydog.com (167.206.37.137) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/cert.pem
  CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
} [232 bytes data]
* TLSv1.2 (IN), TLS alert, close notify (512):
{ [2 bytes data]
* error:140043E8:SSL routines:CONNECT_CR_SRVR_HELLO:reason(1000)
* Closing connection 0
[kyle] ~ $ curl https://themannerlydog.com -svo /dev/null --tlsv1.2
*   Trying 167.206.37.137...
* TCP_NODELAY set
* Connected to themannerlydog.com (167.206.37.137) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/cert.pem
  CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
} [232 bytes data]
* TLSv1.2 (IN), TLS alert, close notify (512):
{ [2 bytes data]
* error:140043E8:SSL routines:CONNECT_CR_SRVR_HELLO:reason(1000)
* Closing connection 0
[kyle] ~ $ curl https://themannerlydog.com -svo /dev/null --tlsv1.3
*   Trying 167.206.37.137...
* TCP_NODELAY set
* Connected to themannerlydog.com (167.206.37.137) port 443 (#0)
* LibreSSL was built without TLS 1.3 support
* Closing connection 0


That is not the IP address advertised by Cloudflare. It’s someone’s cable provider (Cablevision/Optimum) IP address.

1 Like

I recognized that but I wasn’t sure what it meant. I know that my DNS records have already propagated. DNS checker

Is this something that my internet provider could be doing somehow?

I have no idea what local DNS your devices are using. Many people use better DNS than what their ISP provides. Personally, I set my router to use 1.1.1.1 for primary and 9.9.9.9 as secondary DNS. Then my devices update from my router setting.

Firefox is probably working because it’s using an internal DNS setting that’s correct.

@sdayman I had not set default DNS servers on my router. The router chose some default servers which were apparently bad. Setting my DNS servers to the ones you use makes everything work.

I don’t understand why the DNS servers that were being used were wrong, but I guess there’s not much that I can do about it.

Thank you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.