Site is not getting redirected to HTTPS

Hi everyone,

I’ve enabled “always use https” and I have also created page rules but still my site isn’t getting redirected to https for this particular url: http://www.example.com

Rest all the urls are getting redirected automatically. But this one’s not moving an inch even after I’ve tried everything.

Now, what am I suppose to do?

Please help me out!

Can you share the domain?

2 Likes

Hello,
As stated by MarkMeyer, it would be great to know which URL are you having issues with?
(we assume it’s actually not http://www.example.com ?)
We could run some tests then.

2 Likes

You shouldnt need a page rule if you’ve enabled Always use HTTPS. This thread has more info:

@MarkMeyer @nicgayerie
Here’s the URL: https://www.apkfi.com/

Now, my site is working fine. After setting page rules, enabling “Always Use https”, I enforced a redirection in the .htaccess file in my cpanel, and I waited for few hours, may be around 6-8, then my site started working fine. Now it opens on https only with all the URLs.

But still, I would like to know that does it take 6-8 hours after doing all these things for redirection? Is it normal?

It sounds odd, such a change should usually be applied in a matter of seconds.
You should be able to remove the redirection on your side and rely on the redirection at the Edge.
You did the right thing:

At least now it’s working fine! I’m happy!

And thanks to you people for responding so fast.

Hi @smarsh

It wasn’t redirecting to https even after enabling Always use https, which is why I had to create page rules, now let me turn them off and see whether it’s still working fine or not.

Once you’ve set up HTTPS, make sure that all unsecure HTTP traffic to your site is redirected to HTTPS: Use canonical links in the head of your HTML page to help search engines figure out the best way to get to the page. Configure your server to redirect HTTP traffic to HTTPS:

This topic was automatically closed after 14 days. New replies are no longer allowed.