Site is Down - DNS Issues

Hello,

I have issues connecting to my website.

www.silvermoneyservices.com

I think it’s a DNS issue but am not sure what it is.

Please find below all DNS records:

Can you please let me know how I can fix it?

Thank you for your help :slight_smile:

JM

That first entry should only say: www

I don’t know how that Cloudflare-resolve-to would have gotten into there.

I changed to www but still not working :frowning:

{IP address redacted by admin}

Thanks!

JM

Can you scroll down to the Name Servers section? It should say you’re using the Erik and Ivy servers.

Yes I think they are correct :slight_smile:

Absolutely nothing is showing up for me. It looks like you’re doing everything correctly. Open a Ticket:
Login to Cloudflare and then contact Cloudflare Support by clicking on the Get More Help button.

I am able to load site securely in incognito on mobile.

2 Likes

I’m mobile (always a struggle for me) and couldn’t get records from What’s My IP. And neither VPN could connect. Turned off VPN and it’s loading now.

What’s wrong with this picture:
https://www.whatsmydns.net/#A/silvermoneyservices.com

Now I see. You’ve lost the root domain entry: silvermoneyservices.com

It works now! Thanks a lot!

JM

2 Likes

So what should I do then?

Thank you!

JM

Hi @jmtruelle, fantastic! I’m on desktop now and see some mixed content issues on the site with scripts. Certificate is in place, but the site is showing not secure due to the mixed content.

Mixed content errors mean that your website is being loaded over HTTPS but some of the resources are being loaded over HTTP. To fix this you will need to edit your source code and change all resources to load over a relative path, or directly over HTTPS.

For example, if you load your images with a full URL:

<img src="http://example.com/image.jpg" />

You would want to change this to:

<img src="//example.com/image.jpg" />

By removing the http:, the browser will use whichever protocol the visitor is already using. An alternative option would be to enable the Automatic HTTPS Rewrites feature that can potentially fix these errors for you automatically. Do be aware that resources loaded by JavaScript or CSS will not be automatically rewritten and mixed content warnings will still appear. See this Community Tip for further details on how to fix. Suspect you’ll need to go the route of manually editing http out as the issue is with a script (in Chrome, note the small shield and red X on the address bar).

1 Like

Hello,

Thank you for your help :slight_smile: Much appreciated.

I did enable automatic https rewrite a few minutes ago. It might need some time to propagate no?

Thank you!

JM

No, it should be pretty much automatic. but, that switch does not affect http calls that are made for javascript or css files, you need to edit those to a relative reference. http:// becomes //.

Put the A record back in. Your original post has it right before the ‘ssh’ entry.

1 Like

You got me confused.

What’s the right record then?

What about www version ie. www.silvermoneyservices.com

Thanks!

You need both. You deleted the A record for silver money services.com when you fixed the www entry.

Hello,

Thank you for your help on that. It works now.

I am getting similar issues with other websites:

I use the same process but I get an error for the following websites:

http://www.oneconnectionmedia.com/

http://www.studenthelpforum.com/

Any thoughts on what I am missing?

Thanks

JM

The first one is working. The second one is giving a 500 Internal Server Error message.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.