Site is Down - DNS Issue

Hello everyone,

I have a website www.thrivehouses.com and for some reason it keeps going down.

I think it’s a DNS issue but I am not an expert at it.

It seems to be due to Cloudflare but I am not sure what I need to change in settings to make it work.

It’s a simple website. I just want to make it work :slight_smile:

Thank you for your help!

JM

What does this mean?

Site is down. It says “Site not found”.

I think there is a mix up with DNS records. Not sure how to set up proper DNS configuration.

That comes straight from your server and means your server is not configured to recognise your “www” hostname. You’ll need to contact your host about that.

Removing the ‘www’ doesn’t help much, either. So much for recommending a redirect Page Rule.

But my host is Cloudflare. I have my domain name there.

And when I go to Dreamhost, it says that these settings are run by Cloudlfare.

Cloudflare is not a web host. It’s more of a performance firewall for your existing site.

What DNS settings should I put? I really don’t understand what’s wrong :frowning:

The DNS records here “A”, CNAME, MX, TXT, etc. should match the DNS records at your webhost.

Yes I know that but I bought my domain name through them so DNS settings are going through Cloudflare and this is where I am having a problem. I don’t understand what are the correct DNS settings.

Interesting, earlier I had the impression it did work :man_shrugging:t2:

Right now even HTTPS does not work any longer, though the server seems to be up.

@jmtruelle, does the IP address configured in your Cloudflare DNS panel end in 90? Also, whats the chosen SSL mode on the Crypto page? “Full strict” should work for you.

I have 2:

A

www
points to 173.236.178.255
Automatic
Delete

A

www
points to 208.97.176.90

SSL is “Full Strict”

You shouldn’t have two DNS records for www. If @sandro is correct, then you should delete the 255 one. It doesn’t look right anyway.

Remove the first entry, assuming that IP address is not correct any longer.

Does he doubt @sandro? :crazy_face: :laughing:

“Trust, but verify.”

Dont trust, believe! Then you can scrap “verify” too. Ask the church :smile:

Also, did somebody just say my name? :wink:

1 Like

Ok done. Thank you for your feedback.

Let’s see how it goes :slight_smile:

1 Like

Seems to work fine now, right?

1 Like

Yes! Thank you so much :slight_smile:

That was a simple fix. Apologies for the inconvenience.