Site goes offline when cloudflare is activated

I have activated HTTPS with Ionos contract, but still when I activate the website with Cloudflare - the website goes offline, says I need to clear cache, but that doesn’t work. What else do I need to do to make this work, I have setup the correct nameservers with the hosting exact to instructions.

Greetings,

Thank you for asking.

May I ask you to post and share your domain name in bracketed dot [.] notation here and URL example to the particular resource with us so we could double-check, troubleshoot and provide some feedback information? :thinking:

Are all the DNS records correctly configured at the DNS tab of Cloudflare dashboard for your domain name?

May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Before moving to Cloudflare, was your Website working over HTTPS connection?

Before doing anything at Cloudfalre settings, you could determine if you have a valid SSL certificate installed at the origin host/server by your web hosting provider or your own VPS/dedicated server following the steps from below:

  1. Use the “Pause Cloudflare on Site” option from the Overview tab for your domain at dash.cloudflare.com .
  2. The link is in the lower right corner of that page.
  3. Give it five minutes to take effect.
  4. Check with your hosting provider / cPanel AutoSSL / ACME.sh / Certbot / Let’s Encrypt or some other and renew it accordingly.
  5. Make sure site is working as expected without any errors via HTTPS.
  6. Only then should you un-pause Cloudflare and double-check your SSL/TLS setting to make sure it’s Full (Strict).

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

Thank you for your extensive inquiry. The website is being hosted with ionos and with Plesk as the server. I have the following within the Plesk DNS settings: the same settings are used in ionos nameserver. I have Cloudflare paused right now. I have also cleared Cache, and other browsers and computers, the same is on the phone. The SSL/TLS is set as Flexible. (I removed the [.] out of items so they are not seen as links within this post which don't seem to be allowed. 
hank  ns.cloudflare com

piper  ns.cloudflare com

the domain is [sunstonemp com]

here is all the DNS settings in Cloudflare: 
Type          Name                                                          Content
A                sunstonemp com                                        108.175.13.171
A               www                                                             108.175.13.171
CNAME    Autodiscover                                                 adsredir.ionos.info
CNAME  _domainconnect                                             m6x4c8d7.rocketcdn.me
MX            sunstonemp com                                         mx00.ionos.com
MX            sunstonemp com                                         mx01.ionos.com
TXT         _dmarc                                                          v=DMARC1; p=none; rua=mailto
TXT           sunstonemp com                                         v=spf1 ip4:108.175.13.171 include

The cloudflare nameserver is:
NS      hank.ns.cloudflare com

NS      piper.ns.cloudflare com

Hi - there - is someone there to help, have you investigated my issue further?? Do you only give pre-generated responses here??

I’m pretty sure a good portion of that was hand-typed, and is a great start to troubleshooting most site issues here.

Now that you have Paused Cloudflare, I can see that the site works, but not the ‘www’ hostname. That can be fixed with a Page Rule (tutorial at bottom of this post) once you unpause Cloudflare.

Do you have a screenshot of that? That doesn’t sound like a typical Cloudflare error message.

From my cursory test, it’s in a redirect loop and that your SSL/TLS setting here is probably Flexible, instead of Full (Strict).

Once back on Cloudflare, this tutorial has the Page rule for redirecting www to the apex domain, which currently works.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.