Site giving 404 after changing A record

Hello
10 h ago I did change A record on Cloudflare DNS for my migrated site and although on my actual hosting (Bluehost) they say that everything is right with the WordPress install and DNs is propagating, I get 404 whenever I try yo access the site on front end and also when I try to use the wp-ligin.php. On the Dashboard at Cloudfare I did only change the A Record because it’s what they told me to do. CNAME are not updated yet. Can you help me with this? I still have some tasks to perform on the site and need access to the backend. The url of the site is atuavidanoastros.com
Thanks

The domain you mentioned is not registered in the first place.

yes it is registered on cloudflare. Until august 23 2021.

i am sorry i did spell it wrong: atuavidanosastros.com

Does the IP address you configured on Cloudflare end in 49?

No, it ends on 94

That is presumably not correct. Double check it with your host though.

I didn’t set Cloudflare plugin yet on the new site and did not use the old installation of WordPress, did only import posts, images and pages and rebuilt the site in a new WordPress install, I don’t know if this matters for the issue. I still have to update permalinks. Also, the site is set not to be crawled by bots, because I thought I would have access to the backend later but it was not the case.

A plugin is not the issue, the issue appears to be an incorrect IP address. From what I can tell it should end in 49. If that is the case you should correct that.

I did go check and the IP address that finishes in 49 is the old one. My account is still active there, but I did set correctly the new IP address. Maybe I have to disablle the old Ip address?

Did you change host?

yes from Godaddy to Bluehost

That explains it then.

Your host has not configured your site for HTTPS, there is no valid certificate and it does not even respond to the invalid certificate. Your host needs to fix that. You need a proper configuration and valid certificate on your server.

yesterday they told me that when the DNS propagate I would have automatically the SSL enabled. do i need to change something on ssl app cloudflare? Because I have been using godaddy’s ssl

You need to contact your new host and sort out the SSL issue. I mentioned what they need to do in my previous posting.

Ok I am going to fo this and after that will come here to say if it is fixed. Thanks you very much

I did contact the host support and they did show me that the SSL was enabled (seen on sslshopper.com). But explained to me that the SSL only works on they own IP and can’t work on a cdn. so, told me that it would be better to disable it.
Now, at Godaddy, for this site, I don’t have a SSL that can be used because this one came withthe plan. What should i do? Because i know that cloudflare does not work without a SSL on the hosting right? I did change for this new host because read they are partners of cloudflare, so, thought that they would be more friendly with this kind of settings. I am leaving a plan with almost a year paid ahead so, please some insights will be welcome. The plan on bluehost is the pro.
Thanks

I am not quite sure what that is supposed to mean at all, but SSL is not related to any IP (save for any possible certificate validation, but thats a different subject). You need your HTTPS configuration fixed. If they cant do that I would suggest you revert back to your old host, as your 49 address does have a valid certificate

Thanks for the reply. They 've just told me that did revert the site to http to let me in an hour log into the site on backend. But this doesn’t solve the issue, I will probably reverse back to the previous host if they don’t find a solution.

They dont need to revert back, they simply need to configure HTTPS properly.