Site fails to load browser thinks it untrusted after being trusted for over a year

Answer these questions to help the Community help you with Security questions.

What is the domain name?

Have you searched for an answer?
yes, no obvious match

Describe the issue you are having:
Suddenly the browsers (Chrome and Firefox) are not trusting the supposedly “trusted” site


OK I cleared/purged ALL the cache at cloudflare where I get the free SSL, while it seems it worked on the on chrome, if I tried control-refresh it gives unsecure site and the above shows on the console.
In firefox it always gives unsecure site.

What error message or number are you receiving?

When my site tries to load images with the following URLs it fails:

This site can’t be reached… see snapshot

  1. Your connection is not private… see snapshot

Was the site working with SSL prior to adding it to Cloudflare?

What are the steps to reproduce the error:

Have you tried from another browser and/or incognito mode?

Please attach a screenshot of the error:

This is not an issue with Cloudflare because a) the above statement and b) isn’t proxied through Cloudflare rather requests are going direct to origin.

You need to add SSL to your origin server.


Even though I managed to configure my domain registrar at a year ago or rather cloudeflare to obtain essentially free SSL by having cloudflare cache my site (at least that’s what I understand) and I am no GURU at this.

What changed that’s causing my site to not be trusted or not resolve correctly?

I host my VPS at and I can reach my files just fine with ftp however it’s the browsers that couples days ago suddenly started failing.

Did somehow my VPS IP change and I need to make an update?
Where exactly do I need to RE-configure SSL ?

  1. at the domain registrar
    or 2) on some apache config file?
    or 3) on cloudflare ?

Can you please assist me in simple terms.
Thank you.

PS. This SSL on cloudflare has been working smoothly for almost a year now.

According to my logs (alternative brain) I updated to the new VPS IP back in May 13th


The new IP is the one showing in DNS records.

You need to do this on the VPS. This is because, as previously mentioned, all requests are going directly to this—you are not proxying requests through Cloudflare. (which is on the same VPS I assume) is proxied through Cloudflare, and is working.

1 Like

Here is my configuration at the registrar for

Here is the configuration at cloudflare…

Does this say it is proxied via cloudflare?

I don’t see anything I did different between which is working
and which not working

quick test I can’t reach

but I can reach

This is nothing to do with DNS. You need to configure SSL on the VPS.

And article such as How to: Install Certbot-auto on Ubuntu Linux VPS to Create SSL Certificates from Sky Silk will help you with this.

And if it doesn’t help try contacting Sky Silk support.

This community can help with Cloudflare related issues, and this is to do with your VPS, not Cloudflare.

1 Like

Yes it is proxied.

Where should I be looking? into the apache .conf files
I have not touched the certificates from back where there were created when I decided to use Cloudflare for SSL.

Below these records are the Cloudflare nameservers issued for the domain. What are they?

This issue is your nameservers. They are not configured correctly at the registrar

These are the nameservers configured for

$ whois | grep 'Name Server'
Name Server:
Name Server:
Name Server:

You need to configure them correctly with the appropriate Cloudflare nameservers.


Oh I just discovered that as well…minutes ago I must have missed this step
I don’t understand however how the site has been working since 20220512 ???

I have just deleted those 3 records and replaced with cloudflare nameservers

I guess I have to wait for propagation to take effect?

I now have…much like

When looking at all the notes loging I did a year ago back on 20220512 it says cleary I already went thru all these steps including setting the nameserver to cloudflare so somebody undid this.
Actually I can see on that on
20221213 the records were showing cloudflare
and on
20230708 (like 4 days ago) somebody changed back to the old settings.
I need to find out from who this somebody is ??? hackers or their system restored old values
because I did NOT.

BTW, this is becoming ridiculous limiting posters only one 1 image attachment and no editing :slight_smile:

Thanks for all the help.

My notes don’t fail me…
This is DEJA VUE

Also allowing paste image from clipboard would be great instead of having to save snapshot to a file first.

Thanks !!!

This is due to your trust level.

I don’t see anything hard about taking a screenshot and dragging the file to the post box. Do it regularly.

This is nothing to do with Cloudflare. Direct this suggestion to Discourse who maintain the forum platform.


You must be using those funky case-sensitive platforms derivatives of Unix :slight_smile:
My old trusted snapshot has no drag and drop, well really the platform has just a concept of an invisible :frowning: clipboard cut/copy paste operations.
Yep crappy Windows11 but at least it’s not case sensitive :slight_smile:
Thanks for helping narrow it down for my 60+ years old brain.
I am going to follow up with the folks at to understand who created this grief for me.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.