Site email is not working

I just switched hosting companies for my site and have transferred the files and changed the IP on cloudflare to the new server. Everything is working except the email generated from the site.

I have re-entered all the info correctly (SMTP host, SMTP username, SMTP password & port) but still not working.
It does send email, if I set it to Site Mail (default) but not when I have it set to SMTP.
Any suggestions would be great.

Thanks,
Trent

What is the domain name in question?

As long DNS setup is correct, it should work as per your SMTP services provider.

vee.red
sorry about that.

It’s ok. Are you trying to use E-mail services from Namecheap web hosting right now?

correct

the email does send and receive, just not the system generated ones (welcome email, etc)

It’s completely up to Namecheap. You can take a screenshot of DNS and show to Customer support team so they can verify if all records are in the place.

@trent4 Make sure SPF record is correct.
image

If you are running mission-critical project where receiving email from Contact Forms are important, I’d recommend avoid using web hosting e-mail thing, it may have various reason of unreliability.

I understand previously might be working, but still I’d recommend switch to a proper SMTP provider such as “AWS SES”. It will cost less than a cent. At the end you will have a reliable system in place.

In WP, You can integrate SES via WP SMTP plugin in case of WordPress or manually it can be done as well without any plugin.

ok. I’ll follow up with them to see what issue might be and look into AWS SES. Cool Thanks for that tip.

1 Like

Hi @trent4,

Your MX record points to a proxied hostname at the moment. You should point it to something like mail. and set that to :grey:.

hi dom, I just saw your post. lol So this does mean something.

Previously, were you using Hostgator? I guess, SPF record need changes as per Namecheap.

Your MX record points to mail.vee.red, so you need to set the mail record to :grey:

forgive me…what does that icon mean?

:orange: means that your site is proxied so the requests go through Cloudflare. :grey: means it is DNS only, so it bypasses Cloudflare’s services. Cloudflare doesn’t proxy email, and anything not web based should be set to :grey: - mail, FTP etc.

so my MX shows Name:vee.red Content:mail.vee.red TTL: Auto Proxy status is DNS only

up above A record mail is the IP of my server Auto and Proxied

Are the setting correct?

This is what should not be proxied. The A record for mail should be :grey:.


this, right?

set it to DNS only

Yes, that’s it.

ok. I’ll try that. thank you