Site Down. Server support says its Cloudflare


My site has been going down on and off for over 24 hours now. It’s also showing as not secure (which is new. It has been working fine and showing secure for a month). My server support is saying it’s Cloudflare SSL because the name servers are with CloudFlare.

I had one support agent from my server side two days ago say that there were two SSL’s which were causing a problem so they removed my SSL from BlueHost. Now the website has gone to complete ■■■■ and doesn’t work at all. They’re now saying CloudFlare support needs to assist. I’m not sure what to do. I’m at a loss. How do I go about pointing an SSL to a different IP? I’ve looked through every tab and can’t figure it out.

My DNS points to the right IP but apparently my SSL doesnt? Any help is much appreciated. Apparently I need to ask CloudFlare to enable the SSL from CloudFlares and and provide the following:

It’s showing a 520 error, which generally means the server is erroring out when trying to deliver content.

For starters, go to the Overview tab here and click “Pause Cloudflare on Site” in the lower right corner, then give it five minutes to take effect. That will bypass Cloudflare so you can make sure your server is properly working with HTTPS.

A 520 error occurs when the connection started on the origin web server, but that the request was not completed. The most common reason why this would occur is that either a program, cron job, or resource is taking up more resources than it should causing the server not to be able to respond to all requests properly.

You can review the Quick Fix Ideas in this Community Tip for troubleshooting suggestions.

1 Like

Thanks Sdayman.

Edit: nevermind. Got the overview tab.

So if I visit my site and it now shows HTTPS then it’s a cloudflare issue? A support agent deleted my SSL a couple of days ago off Bluehost as well.

When visiting the site now, I get a warning saying it’s not secure and it also says " This server could not prove that it is ; its security certificate is from * . This may be caused by a misconfiguration or an attacker intercepting your connection."

That was a terrible thing to do. They’ve broken the encryption on your site. As I said, Pause Cloudflare and make sure your site works with HTTPS.

1 Like

I’ve turned it off and the website doesn’t even work. So surely it’s the servers problem?

It loads…just not with HTTPS. Tell them to put SSL back on. It’d be better if you could do it yourself with a Cloudflare Origin Certificate.

If I tell them to put SSL back on, should I still be creating a Cloudflare Origin Certificate or just have one or the other?

Try the Origin Cert. That will give you some control over this issue. But if your host won’t let you add your own cert, they’ll have to restore your old SSL.

Thank you sdayman, I will try to contact support once more and see if I can find one with a braincell.

1 Like

Each agent is telling me something different. Some say put my DNS to “full” others tell me to put it to “flexible”. It’s never consistent. And they’re ignoring my request to put the SSL back on. So frustrating.

Their advice is terrible. Your best bet is to get a new host. Find a host that respects HTTPS.


I’m looking at my down error reports and see the following:

“Error [ERR_TLS_CERT_ALTNAME_INVALID]: Hostname/IP does not match certificate’s altnames: Host: is not in the cert’s altnames: DNS:*,”

Is that because they deleted my SSL?

Yes. I have no polite words for what they did to you.

It seems one out of every 10 support agents I get knows what they’re talking about. This one has reinstated my SSL and it seems my site is secure again. There have been none stop issues with this host, I will be looking for a new one for sure. Im still confused on why i’m being told to put DNS to “flexible” by some agents and “full” by others, but at least my site seems to be working again… Down for over 24 hours. Who knows how badly that hurt my search ranking results. Only time will tell. Thank you for your help sdayman.

1 Like

Flexible and Full are two ways to ignore the lack of a secure connection to a site.

I see. Well knowing that, would you recommend I have it on full or keep it as flexible?

Full (Strict) is the only one that’s actually secure.

1 Like

Oh great, here we go again… My site is now going down randomly for 1-3 minutes at a time again. This website is going to be the death of me. Sdayman, I hate to take more of your time, but before I go back to my server support do you know if the following errors are on server side or something wrong with my CloudFlare settings?

“HTTP Status code is 520”

Edit: oh, thats the same error you were explaining in your first response. Now that I have it showing as secure again, I will pause cloudflare and see what happens.


Just as a side note, some hosts do rate limit Cloudflare’s IPs as they see a ton of requests from those as, I wonder how one would figure that one out, they are proxy IPs for all customers.

The 520 error might happen only under Cloudflare for that reason.