Site Down, DNS Not propogating. Help!

I have a site lauriecarlson.com. I switched DNS yesterday morning from Bluehost to Cloudflare. DNS shows correctly on Cloudflare, but it’s not propagated on dnschecker.org. Site won’t load. Traffic is being routed through Cloudflare, but then it’s lost in a loop. I don’t know what to fix. Usually, Cloudflare propagates DNS much faster…
I read a post to try and set the status to DNS only instead of proxied and any changes I make to DNS on Cloudflare give me these errors…

API Request Failed: GET /api/v4/zones/…/speed_testing?host=lauriecarlson.com (504)
Authentication error (Code: 10000)

Usually the nameserver change at the domain registar can take up to 24 hours to apply the changes.

I see the new Cloudflare nameservers.

But, you have the issue with the redirect loop, I assume due to wrongly selected HTTPS (SSL) settings at Cloudflare SSL tab.
What SSL options have you got selected at Cloudflare dashboard?

Or, may I ask if you have had an SSL certificate for your domain/website before moving to Cloudflare?

Regarding Bluehost, here is the tutorial how to connect custom domain at Cloudflare with your Bluehost hosting provider:

May I also ask:

  1. Or, maybe you manage your DNS records for your domain at Cloudflare?
  2. Or, the Bluehost is an integrated hosting partner, so you would need to apply the changes using their interface?

Thanks for taking the time to reply. It’s set to Flexible…

I believe the issue is that the Cloudlfare DNS has not propagated.

DNSchecker shows this

when I try to update any DNS in cloudflare, i get this…

Okay, few issues here.

From the screenshot above, one is the Flexible SSL option instead should be selected Full (Strict) SSL.

The second I see from the screenshot above, the DNS records:

  • A mail should be :grey: cloud - just click on the :orange: cloud and switch it to :grey: to make sure your e-mail would work propperly
  • A ftp - also :grey: cloud
  • CNAME imap, CNAME pop, CNAME smtp - all three also need to be :grey: cloud to make sure your e-mail would work propperly

I’ve set to Full strict for now. A tool i was using wanted it to be flexible… GuruCan.
It won’t let me change the Mail one to be Cloud…
Still doesn’t explain why I can’t change DNS or why DNS records aren’t propagating from Cloudflare.

Authentication error code 10000

I am afraid this could be related to recent maintenance from below links.
I think we should need to wait for some time until it gets fixed.

If not, then we have to check what else could it be.