Site doesn't open without www

I’m having trouble getting my website to load using https without www in the hostname. It’s fine with https and www, but will not load without the www. It also works without the www as long as there is not https.

mydomain.com works
www.mydomain.com works
https://www.mydomain.com works
https://mydomain.com DOES NOT WORK

I need it to work as the last one because I have over 200 social media posts using a link without the www from an older website and the new host cannot handle it without the www.

I made an A record even though the host doesn’t provide an IP address and made the page rule. Here are screenshots. I have tried the page rule without the https:// in the first entry as well with the same result.

That looks good to me.

Can you confirm that the two name servers listed at the bottom of your DNS page are Cash and Kayleigh?

And, if so, can you toggle your “A” record so it’s :grey: DNS Only, then wait five minutes before pinging it (or checking on DNSChecker.org) to confirm that it’s showing the 192 address?

Something just isn’t making the connection to your :orange: Proxied hostname, and it’d be nice to figure out why.

LOOK! Hold off on the above.

Your Page Rule has https:// in front. Remove that, since it won’t match an http request.
And with HTTPS, there’s some sort of certificate error. Can you check your SSL/TLS page at dash.cloudflare.com under Edge Certificates to see the status of the certs? You should have a Universal Certificate that’s active for example.com and *.example.com (your actual domain)

1 Like

Thank you so much. It’s working now. I wasn’t using CloudFlare’s SSL. I had bought my own for my old website and had installed that with the new host. It was supposed to be good for the root and the www domain, but as soon as I removed the https:// from the rule and changed to CloudFlare’s SSL it started working. Thank you. Have a great night!

1 Like

Hi again. I checked it and it’s not working again for some reason. I didn’t change anything to make it not work. Here are the current settings.

Toggle that 192. DNS entry to :orange:.

That seems to have done the trick. It has been working for about 45 minutes now. Thank you.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.