Site doesn't go trough Cloudflare

I have followed all the steps and been added the site to the Cloudflare. I’ve changed DNS’s etc. Cloudflare shows that the site goes through but actually the site isn’t going through it.

I have purged the cache, deactivated/activated/paused Cloudflare but still nothing. The js/CSS/HTML isn’t minified.

Also my email doesn’t work even the icon on DNS page is grey e.g. not going through Cloudflare.

What can be the problem? How can I ‘debug’ it and see what is wrong?

p.s. I have another site with the same settings which are going through it without any issues. If it’s matter, the site is running on Wordpress.

DNS propagation needs some time or maybe your old DNS records are still cached in your PC.

Would you mind to post the URL Here?

Sure, here is EN version of the site:

cPanel of the host is working. The emails aren’t working on webmail, thunderbird, my phone. In the DNS settings only 2 records are yellow e.g. through Cloudflare:

A record for
CNAME record for www is an alias of

What’s the host you connect to with your mail client?

Btw your page ist going through Cloudflare.

Sorry I don’t understand the question. Are you asking which hosting company I’m using?
Where you saw that the page is going through Cloudflare? And if is so, why some settings aren’t applied like Auto minify for example?

 nslookup                              Server:

Non-authoritative answer:

This is a Cloudflare IP :wink:

Now, one after another .
You wrote

To to receive emails you need to setup MX records. Are emails handled by your own server? Or google, Zoho or any other mail service?

They are handled by my hosting server. I didn’t changed anything. Before activating Cloudflare I’ve received emails, once I activated it - I stopped.

What’s the exact error Message?

Are there MX records present on your Cloudflare dashboard?

Ensure that the hostname you use for email is not set to :orange:. Such as, and so on.

This topic was automatically closed after 14 days. New replies are no longer allowed.