Site Confusion Over http/https, other problems

I tried to use Cloudflare but I had problems. (described below).
So I followed the procedure to revert to namecheap.
Now some of the links on my index go to a https:// and others go to http://.
Of the 12 links on my index page, 6 go to httpS:// pages and 6 go to http:// pages.
The https won’t connect with websockets.
How can I fix that?

This is the problem that made me want to get rid of Cloudflare:
My site uses websockets for all the pages linked from index. Websockets require a “connection”. When on Cloudflare none of the links would connect. The page keeps retrying but never connect.

Does this mean you moved the domain away from cloudflare by changing the nameservers and deleting the zone from your cloudflare dashboard?

Is this happening on the site (zone) you moved away from cloudflare or a site still using cloudflare? Can you share the name of the site?

When using cloudflare or after reverting to namecheap nameservers?

Cloudflare does support it, but there are certain settings to check. As per Cloudflare’s help center, you need to have the ‘orange cloud’ turned on for the DNS records that are being accessed. You should check to ensure you are not exceeding the simultaneous connections supported by your Cloudflare plan. Using Cloudflare with WebSockets · Cloudflare Support docs

I can’t seem to answer your questions directly so:
(1) Yes I changed the nameservers and deleted from CF dashboard.
(2) I should have no site still using CF. The site is
(3) Before using CF all connections worked fine. On CF they would not connect. Now back to namecheap the links that go to https// don’t connect but the ones that go to http// will connect. I don’t know how some become https//
(4) Right now I just want to get back to the way things worked before I got tangled with CF.

Thank you. I suspect you had enable automatic https rewrites? If so, cloudflare was a bit of a “bandage” over you site code. Where your code specifies http, the rewrite will ensure it loads over https.

There is a CommunityTip that explains the issue from the point of view of customers that see a mixed content error, I think part of that tip may help resolve the problem, Community Tip - Fixing mixed content errors

This part in particular

  1. To fix this, you will need to edit your source code and change all resources to load over a relative path, or directly over HTTPS. For example, if you load your images with a full URL, <img src="" />, you would want to change this to <img src="//" />. By removing the http:, the browser will use whichever protocol the visitor is already using.

I see that nameserver change is still propagating, DNS Propagation Checker - Global DNS Testing Tool. (Was DNSSEC active on the domain when it was using cloudflare nameservers?)

I see one with a TLD of .cc that is still using cf but that does not matter wrt what you’re seeing on the .cw domain. WRT that domain, it’s difficult to troubleshoot once it’s moved from cloudflare and I suspect the issue you’re encountering now are not related to cloudflare.

Well, it looks like things are “healing”. All the links that went https// are now http// so websockets are connecting.

I can just hope it stays this way.

Oh, I forgot about the .cc site

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.