Site cant open with error DNS_PROBE_FINISHED_NXDOMAIN

My site don’t open with error DNS_PROBE_FINISHED_NXDOMAIN
How to find what is the issue? I’m not sure how to fix this… I restart the server, check domain dns settings, cant find what is causing this issue.
My domain is and the site worked fine 2 days ago when I last checked it.

Works from my end and it’s proxied :orange: using Cloudflare nameservers :thinking:

May I ask have you tried using a different Web browser, or tried clearing your Web browser cache?
How about restarting your router?
How about using a Private window (Incognito mode) or a VPN connection if possible?
Is it the same behaviour on your mobile phone (4G LTE, mobile data, cellular)?

Despite, there are some issues I am afraid :thinking:

Some ideas for troubleshooting:

This is really strange … I tried in few browser and the same error appear. I tried n my phone with cellular data and its the same. Incognito window - same. Now I tried browserstack to test with few browsers but then It actually works but with error for the certificate. This is really strange, what is the problem?

I do not see one.

Would you try clearing the browser cache files?

This is what I see:

Now I tried with a different browser, as well as freshly installed Chrome without any cache and It lods in one browser, but can’t load in Chrome.

UPDATE: I feel dumb. Just restart my router and now is working.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.