Site Cannot Provide Secure Connection

I’m getting this error.

This site can’t provide a secure connection

hinterlandbeer.com uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

I’ve disabled SSL / TLS through CloudFlare because I will establish SSL through my host.

It seems NS has propagated but in checking who.is … I’m getting a lot of random records some that were removed from CloudFlare DNS panel, others that hadn’t existed at all before.

If you want to use Cloudflare without the proxy, you need to go to the DNS tab and disable the proxy by clicking the currently orange :orange: cloud. Once it’s DNS only, Cloudflare will only provide DNS and the TLS connection will go straight to your host.

1 Like

Thank you so much! AR

1 Like