Site cannot open

I am getting this error:

This site can’t provide a secure connection

www.custom.101greetingcards.com uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

Blockquote

I have read similar threads but nothing helps.

I deleted the force SSL plugin on the site
I have a valid certificate issued via host
DNS records for custom and www.custom are orange

SSL/TLS encryption mode is Full and it seems to be ok (it has a green tick next to it) (disabling it didnt help)

Always Use HTTPS is selected

2 Likes

Thank you for the tutorial. I went through it step by step but I didn’t find the solution unless I missed something.

  1. Is there a DNS record for it? Yes, there is an A record set up for both custom.101greetingcards.com and www.custom.101greetingcards.com

2. Check that the DNS record is working correctly
Yes, I checked here and with the link provided and saw an A record with Cloudflare DNS.

3. Check that the subdomain is not too deep
The subdomain is not too deep.

4. Check that the DNS record is set to :orange:
The DNS record for both custom.101greetingcards.com and www.custom.101greetingcards.com is set to orange.

5. Check that HTTPS doesn’t work
I opened https://custom.101greetingcards.com/ and I get the following error:
www.custom.101greetingcards.com uses an unsupported protocol.

ERR_SSL_VERSION_OR_CIPHER_MISMATCH

**6. Do you see a certificate from your server?
Yes, I have a certificate for both the primary domain and the subdomain and it is working on the primary domain and it was working before connecting to Cloudflare.

Another cause I believe is if you’re trying to view the page in HTTPS from a too-old browser (e.g. anything on Windows XP or old Android versions) that doesn’t support SNI

I tried it on the latest Android and a new browser and it still didn’t load. I can’t even get in to my own backend.

I also tried it on Google Lighthouse:

Lighthouse returned error: FAILED_DOCUMENT_REQUEST. Lighthouse was unable to reliably load the page you requested. Make sure you are testing the correct URL and that the server is properly responding to all requests. (Details: net::ERR_CONNECTION_FAILED)

The host you are trying to use www.custom.101greetingcards.com is not covered by the free certificate issued by Cloudflare. Cloudflare acts as an SSL termination endpoint for traffic which is :orange: and presents certificates from the :logo: edge for those connections. If you have ordered an SSL certificate from Cloudflare to cover this second level host or have uploaded your own certificate which covers this host in the SSL section for your zone on Cloudflare then I would recommend contacting support to help you troubleshoot.

2 Likes

This topic was automatically closed after 31 days. New replies are no longer allowed.