Site appears in mobile layout in Chrome

dash-crypto
#1

I wonder why my site always appear in mobile layout on chrome even I visit on my desktop system. Is there any specific settings that needs to be taken care of for chrome browser? In other browsers like IE, Safari my site appears in desktop layout.

#2

That’s usually an issue with the theme or site itself. What’s the domain?

#3

If its a theme issue then it should appear in mobile layout on all browsers but it happens only on Chrome and sometimes it appears in desktop layout on Chrome. Btw. my site is https://www.e-alhuda.com and my staging site (without cloudflare) at https://wordpress-258834-806478.cloudwaysapps.com/

#4

I’m seeing the same issue in all my browsers too and no errors in the console either. Can you put CLoudflare in to Development mode and purge Cloudflare’s cache? Then we can look in to this further.

1 Like
#5

I am afraid if it interrupt my live site because its active and I also have SSL certificate. Will it create any trouble like broken site?

#6

On Firefox it appears in mobile layout too.

1 Like
#7

Development mode just disables caching.

#8

Ok, I have put it on development mode and purged all cache.

#9

Thank you.

I’m still seeing the issue while it’s in Dev mode. The only thing I can suggest is go to https://dash.cloudflare.com/?zone=performance review and temporarily disable your speed settings and purge again. If that doesn’t work, temporarily disable any page rules too.

1 Like
#10

This happen to me on many sites not just cloudflare powered site. Something either wrong with Chomr or windows 10.

1 Like
#11

@zishanj It seems to be working now. What ended up being the solution?

1 Like
#12

This issue was affecting all desktop browsers/OS

1 Like
#13

Nothing I just cleared the site cache internally again.

2 Likes
#14

Did you disable any of the Speed Settings or Page Rules in Cloudflare? If you did, slowly turn them back on one at a time and purging the caches until it breaks.

#15

I wonder why it never happens with my staging site at https://wordpress-258834-806478.cloudwaysapps.com/ Its just a mirror site of live site but without cloudflare.

#16

Nothing changed on cloudflare. But I had 2 cache plugins for image and css optimization in WordPress. I cleared their cache.

#17

Zishanj were you using autoptimize?

#18

Its optimus and cache enabler for images only. I had these 2 enabled on my staging site also but thats working fine.

#19

Tweaking cache settings is an art but pays off the more you test them. One other suggestion, while the site is not slow, there are 143 requests. If you can lower that, you should see more improvement.

#20

Performance is not an issue at the moment. Its about mobile layout on desktop.