Single-file cache purging not working

yes I also experiencing the same.

Hi @benoit.luisier0 Sorry for the issues you are facing, I have opened and updated the ticket so you should see a reply from me in this ticket now.

Hi @tiago.carvalho thank you for sharing this additional information. Are you able to open a support ticket for this issue?

To contact Cloudflare Customer Support, login & go to https://dash.cloudflare.com/?account=support and select get more help. If you cannot login, email [email protected] from the email address on your account. If you receive an automatic response that does not help resolve your issue, reply and indicate that you still require assistance. And, please share your ticket number here so that we can track it.

Hi @SarahA. Thank you for your time. I did that yesterday but I only got an automated response: https://support.cloudflare.com/hc/en-us/requests/2196260

1 Like

@SarahA The ticket is marked as Solved. Should I create a new one?

Hi @tiago.carvalho can you please share the ticket number here?

Sure, this is the ticket number: #2196260

Thank you @tiago.carvalho, sorry for the issues you have been facing. I have opened this ticket and I am looking into this now.

2 Likes

I’m also experiencing the same problem. Custom purge is not working for me. The only way to see the updated contents of my blog is to either do a full domain purge or bypass CF by enabling development mode.

I’ve also created a support ticket: [2197042]

My ticket was automatically changed to ‘solved’ 2 minutes after I created it but I can assure you that I still have the problem.

2 Likes

We’re having the same exact issue. It seems that the incident related to this was not fully resolved.
My ticket id is #2196199

3 Likes

In my case I purged index.html via CF’s website Custom Purge. I purged both https://example.com/ and the same URL with /index.html https://example.com/index.html

When I go to: http://example.com I get the old page.
When I go to http://example.com/index.html I get the new page.

I’ve attempted this many times. A complete purge is not an option for me.

1 Like

Hi @kilobyte2007 and @kris3 I am sorry you are having this issue. I responded recently to your open support tickets and I am researching it there.

@gm13 I am going to open a support ticket for you for us to investigate the issue with purging you are having.

There could be a number of different reasons why purging is not working. They could be related, but there is also the possibility the issues are not related. We are currently not having any incidents with purging, but are checking with our internal teams to confirm.

2 Likes

Thanks a lot, Evan. I have provided all the details in the ticket. What makes me think it is related is:

  1. It started after the reported incident affecting the Single file purge. Maybe it wasn’t really fixed?
  2. It is affecting multiple users around here.
  3. We didn’t touch a thing or any code or server configuration in the last 3 days.
1 Like

I need to add a strange twist to this custom purge issue. I have discovered that when I approve or add a new comment to a post, the page purges correctly.

But what’s even stranger, is that if I make a change to a paginated page and purge it, the change will show on paginated pages, such as paginate comments, but not the base URL.

For instance;

Changes purged and updated on this page.
“how-to-convert-word-to-epub/comment-page-4/#comments

But changes not purged and updated on this page.
“how-to-convert-word-to-epub/”

The only way I can get the main page to purge is to do a full site purge.

Hopefully, there is a fix coming soon for this issue, because it is really handicapping my ability to maintain my site.

@cf_evan I also raised an issue, my ticket number is #2197494.

@cf_evan @SarahA The incident on Jun 28 stated that there were just delays to single-file cache purging (purge by URL). It’s clear from the number of reports on this post that there is and has been for the last 4 days a functional issue with this API, i.e. a single-file cache purge just fails to work, it’s not simply a delay. Could there not have been a code or configuration change or similar that has caused this?

I purge single files also including the origin header via the API, this has worked perfectly for the last 4 years, now it doesn’t work. It’s very easy to reproduce this failure with a test. Is this something your internal teams can do?

1 Like

Just chiming in to add extra confirmation to this: I’m experiencing the same issue as the others in this thread.

We appreciate all the examples everyone provided and reported to us. Our engineering team was able to discover the cause of the issue and implement a fix. We have updated our status page to reflect this incident.

Please let us know if you continue to see any additional issues with single-file purging.

11 Likes