Simple explanation how to let a website through the firewall?

Please could someone explain in simple terms how to allow a third party URL through the Cloudflare firewall? What options do I need to choose in the Firewall Rules?

Background: the third party used to have access to take order details from the website. Since setting up Cloudflare it has stopped working. Attempting to create a new integration throws up a 500 error on screen, but this doesn’t appear in any logs anywhere. The URL no longer appears in any server logs (as it did pre-Cloudflare). My assumption is that Cloudflare is blocking this external website from accessing data.

Check Firewall events and see what caused the blocking.

Hi @erictung

This website (nor any of the IP addresses I know for it) doesn’t appear there. Does that mean Cloudflare is not the cause?

image

There’s a “Pause Cloudflare on Site” button under Overview tab. Can you try to pause the Cloudflare service?

1 Like

Aha! Yes!
I paused Cloudflare. Retried to connect the third party service - it worked instantly.
So it is definitely Cloudflare blocking it.
What to do now?

BTW I really appreciate your help - as someone new to this there are so many things to get your head around!

1 Like

How do you identify the third-party? Is it via IP address? Or their website? User agent?

It is a website - Royal Mail Click and Drop in the UK - they have a web-based interface to connect easily to Woocommerce (and other) websites and take shipping information. The set-up works with Cloudflare disabled, and order details are transferred across.

However, with Cloudflare enabled:

  • no order details are transferred.
  • attempting to set up a new integration with the same settings falls at the first hurdle, with the error message “WooCommerce API returned HTTP response [500]”.

I’ve attempted to allow all of Royal Mail’s IP addresses through the Firewall, plus one URL from a list that they provide. I am just not sure that I am doing it correctly (or if that is the way to go).

HTTP 500 is interesting. Let’s see whether someone in this community knows how to deal with this issue.

1 Like

That’s what I was hoping for, but it doesn’t look good at the moment!

This topic was automatically closed after 30 days. New replies are no longer allowed.