Signed exchange AMP

Hello,
We have a signed exchange AMP issue with our website.
After testing some pages from the website we have received a warning from Google Search Console that the signed exchange is not activated although it is set to be.
How can we solve the issue and activate properly the signed exchange AMP for the website?

2022-06-16_144628

Greetings,

Thank you for asking.

Haven’t had seen this yet :thinking:

May I ask if you are using a Pro plan or?
Furthermore when you navigate to the Speed tab → Optimization, and scroll down a bit:

  1. Is the AMP Real URL feature enabled at Cloudflare dashboard?
  2. Is the Automatic Signed Exchanges (SXGs) feature enabled at Cloudflare dashboard?

Hi @fritex,

Thanks for the help.

Well, AMP Real URL feature was not enabled on the Cloudflare dashboard so I have just enabled it.

The Automatic Signed Exchanges (SXGs) feature was already enabled.

Still, after enabling the AMP Real URL feature I have inspected a URL by GSC and it still shows the same warning.

We are using a Pro plan.

Either use AMP Real URL, or else the BETA “Automatic Signed Exchanges”.
You cannot have both, as far as it would cause issues.
Having SXG enabled will throw some errors at GSC about AMP I think.

Nevertheless, as far as SXGs are BETA I wouldn’t recommend to use it on your production Website.

After enabling/disabling, give it at least 24-48 hours for Google to pick up the changes, if so.

A very long topic about it here:

@fritex, I’ve got it back to “Automatic Signed Exchanges” only, left it for a day and now it works perfectly as far as I see.
It seems as it only needed a small off-and-on to kickstart it. :slight_smile: