Shows NOT SECURE on top left tab of the browser on my website

#1

Hi I just Set up Cloudflare and pointed nameservers also www was set through cloudflare but my site is still says NOT SECURE on the tab there. The website is utpland.com

Any help or suggestion would be greatly appreciated

Thank you!

0 Likes

#2

Hi! You should probably enable ‘Always use HTTPS’ in the Crypto tab of your Cloudflare dashboard if you want all visitors to see the secure version. There also look to be a few mixed content issues. Check this post out for some tips :slight_smile:

0 Likes

#3

thanks for the help, now if i go to the https://www.utpland.com on the right side of the address bar it says the site is trying to “load scripts from unauthenticated sources” is it because there might be mixed contents? but I also enabled “Automatic HTTPS Rewrites”

  • I just activated Cloudflare couple hours ago though, would that be the reason?

Thank you

0 Likes

#4

Yes, that is likely mixed content.

will fix a lot of the issues but not all of them, some do need to be fixed on your site/server.

It shouldn’t be, it appears to be working fine, just with these mixed content issues.

1 Like

#5

Ok thank you I will change all the links to https://

1 Like

#6

BTW it still didn’t redirect from http to https yet whenever I the website address
http://www.utpland.com

0 Likes

#7

It redirects OK for me, try clearing your cache, or wait a while.

0 Likes